Read the docs
TI-2023-17074 Aliases CVE-2023-34238GHSA-c6f8-8r25-c4gc

Local File Inclusion vulnerability in Gatsby

Priority LOW 26CWE-22Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
Low · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-22 and the CVSS impact.

Summary

Gatsby is a free and open source framework based on React. The Gatsby framework prior to versions 4.25.7 and 5.9.1 contain a Local File Inclusion vulnerability in the `__file-code-frame` and `__original-stack-frame` paths, exposed when running the Gatsby develop server (`gatsby develop`). Any file in scope of the development server could potentially be exposed. It should be noted that by default `gatsby develop` is only accessible via the localhost `127.0.0.1`, and one would need to intentionally expose the server to other interfaces to exploit this vulnerability by using server options such as `--host 0.0.0.0`, `-H 0.0.0.0`, or the `GATSBY_HOST=0.0.0.0` environment variable. A patch has been introduced in `[email protected]` and `[email protected]` which mitigates the issue. Users are advised to upgrade. Users unable to upgrade should avoid exposing their development server to the internet.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0091 60th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed gatsby (gatsbyjs): 5.9.1, 4.25.7gatsby (npm): 4.25.7, 5.9.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
gatsbyjsgatsby5.0.0 to before 5.9.1; before 4.25.75.9.1, 4.25.7Patch availableCNA
—gatsby (npm)before 4.25.74.25.7Patch availableGHSA-c6f8-8r25-c4gc
—gatsby (npm)5.0.0 to before 5.9.15.9.1Patch availableGHSA-c6f8-8r25-c4gc
  • gatsby Vendorgatsbyjs Affected 5.0.0 to before 5.9.1; before 4.25.7 Fixed in 5.9.1, 4.25.7 Patch available CNA
  • gatsby (npm) Vendor— Affected before 4.25.7 Fixed in 4.25.7 Patch available GHSA-c6f8-8r25-c4gc
  • gatsby (npm) Vendor— Affected 5.0.0 to before 5.9.1 Fixed in 5.9.1 Patch available GHSA-c6f8-8r25-c4gc

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:gatsbyjs:gatsby:*:*:*:*:*:node.js:*:*before 4.25.7; 5.0.0 to before 5.9.1Vulnerablegatsbyjs
  • cpe:2.3:a:gatsbyjs:gatsby:*:*:*:*:*:node.js:*:* Versions before 4.25.7; 5.0.0 to before 5.9.1 Vulnerable ·gatsbyjs

Remediation

  • Fix · CNA gatsby (gatsbyjs) Fixed in 5.9.1, 4.25.7
  • Fix · GHSA-c6f8-8r25-c4gc gatsby (npm) Fixed in 4.25.7 Advisory →
  • Fix · GHSA-c6f8-8r25-c4gc gatsby (npm) Fixed in 5.9.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-34238
  2. 2026-10-03 Alias added: GHSA-c6f8-8r25-c4gc

References

Sources