Weak passwords allowed in cloudexplorer-lite
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-521.
Summary
Cloudexplorer-lite is an open source cloud software stack. Weak passwords can be easily guessed and are an easy target for brute force attacks. This can lead to an authentication system failure and compromise system security. Versions of cloudexplorer-lite prior to 1.2.0 did not enforce strong passwords. This vulnerability has been fixed in version 1.2.0. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| 1Panel-dev | CloudExplorer-Lite | before 1.2.0 | 1.2.0 | Patch available | CNA |
- CloudExplorer-Lite Vendor1Panel-dev Affected before 1.2.0 Fixed in 1.2.0 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:fit2cloud:cloudexplorer_lite:*:*:*:*:*:*:*:* | before 1.2.0 | Vulnerable | 1Panel-dev |
- cpe:2.3:a:fit2cloud:cloudexplorer_lite:*:*:*:*:*:*:*:* Versions before 1.2.0 Vulnerable ·1Panel-dev
Remediation
- Fix · CNA CloudExplorer-Lite (CloudExplorer-Dev) Fixed in 1.2.0
Timeline
- 2026-10-02 Threatist record created from CVE-2023-34240
References
More 1Panel-dev Cloudexplorer Lite vulnerabilities
- TI-2023-20041 Command injection vulnerability in module management function in CloudExplorer Lite CVSS 3.1CRITICAL 9.8
- TI-2023-23903 CloudExplorer Lite permission bypass vulnerability CVSS 3.1CRITICAL 9.8
- TI-2023-20651 CloudExplorer Lite sensitive information leakage vulnerability CVSS 3.1HIGH 7.5
- TI-2023-22509 An issue in CloudExplorer Lite 1.3.1 allows an attacker to obtain sensitive information via the login key component. CVSS 3.1HIGH 7.5
- TI-2023-02666 Improper Access Control in cloudexplorer-dev/cloudexplorer-lite CVSS 3.1HIGH 8.1
- TI-2023-27633 Insecure Permissions vulnerability in fit2cloud Cloud Explorer Lite version 1.4.1, allow… CVSS 3.1HIGH 7.8
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences