OS command injection in QNAP QTS
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-78.
Summary
An OS command injection vulnerability has been reported to affect several QNAP operating system versions. If exploited, the vulnerability could allow authenticated administrators to execute commands via a network. We have already fixed the vulnerability in the following versions: QTS 4.5.4.2627 build 20231225 and later QuTS hero h4.5.4.2626 build 20231225 and later
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| QNAP | QTS | 4.5.x to before 4.5.4.2627 build 20231225 | 4.5.4.2627 build 20231225 | Patch available | CNA |
| QNAP | QuTS hero | h4.5.x to before h4.5.4.2626 build 20231225 | h4.5.4.2626 build 20231225 | Patch available | CNA |
- QTS VendorQNAP Affected 4.5.x to before 4.5.4.2627 build 20231225 Fixed in 4.5.4.2627 build 20231225 Patch available CNA
- QuTS hero VendorQNAP Affected h4.5.x to before h4.5.4.2626 build 20231225 Fixed in h4.5.4.2626 build 20231225 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:qnap:qts:*:*:*:*:*:*:*:* | 4.5.1 to before 4.5.4.2627 | Vulnerable | QNAP |
| cpe:2.3:o:qnap:qts:4.5.4.2627:-:*:*:*:*:*:* | 4.5.4.2627 | Vulnerable | QNAP |
| cpe:2.3:o:qnap:quts_hero:*:*:*:*:*:*:*:* | h4.5.0 to before h4.5.4.2626 | Vulnerable | QNAP |
| cpe:2.3:o:qnap:quts_hero:h4.5.4.2626:-:*:*:*:*:*:* | h4.5.4.2626 | Vulnerable | QNAP |
- cpe:2.3:o:qnap:qts:*:*:*:*:*:*:*:* Versions 4.5.1 to before 4.5.4.2627 Vulnerable ·QNAP
- cpe:2.3:o:qnap:qts:4.5.4.2627:-:*:*:*:*:*:* Versions 4.5.4.2627 Vulnerable ·QNAP
- cpe:2.3:o:qnap:quts_hero:*:*:*:*:*:*:*:* Versions h4.5.0 to before h4.5.4.2626 Vulnerable ·QNAP
- cpe:2.3:o:qnap:quts_hero:h4.5.4.2626:-:*:*:*:*:*:* Versions h4.5.4.2626 Vulnerable ·QNAP
Remediation
- Fix · CNA QTS (QNAP Systems Inc.) Fixed in 4.5.4.2627 build 20231225
- Fix · CNA QuTS hero (QNAP Systems Inc.) Fixed in h4.5.4.2626 build 20231225
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
QNAP Systems QTS 4.5.4.2627 build 20231225
2 records Highest priority Priority MEDIUM 2 MEDIUM
Other records, highest priority first
- TI-2024-14561 SQL injection in QNAP myQNAPcloudPriority MEDIUM 40
Timeline
- 2026-10-02 Threatist record created from CVE-2023-34980
- 2026-10-03 Alias added: GHSA-6pc8-76w2-c62h
References
More QNAP Qts vulnerabilities
- TI-2020-02221 Command Injection Vulnerability in QTS and QuTS hero KEVCVSS 3.1CRITICAL 9.8
- TI-2019-05101 Improper input validation in QNAP NAS devices KEVCVSS 3.1CRITICAL 9.8
- TI-2018-14137 Improper input validation in QNAP QTS KEVCVSS 3.1CRITICAL 9.8
- TI-2014-05975 GNU Bash through 4.3 bash43-025 processes trailing strings after certain malformed… KEVCVSS 3.1CRITICAL 9.8
- TI-2014-05157 GNU Bash through 4.3 processes trailing strings after function definitions in the values… KEVCVSS 3.1CRITICAL 9.8
- TI-2018-14131 Cross-site scripting in QNAP QTS KEVCVSS 3.1HIGH 8.0
Sources
- CVE-2023-34980 · CVE Program
- CVE-2023-34980 · NVD
- FIRST EPSS
- GHSA-6pc8-76w2-c62h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences