Envoy vulnerable to incorrect handling of HTTP requests and responses with mixed case schemes
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat.
Summary
Envoy is an open source edge and service proxy designed for cloud-native applications. Envoy allows mixed-case schemes in HTTP/2, however, some internal scheme checks are case-sensitive. Prior to versions 1.27.0, 1.26.4, 1.25.9, 1.24.10, and 1.23.12, this can lead to the rejection of requests with mixed-case schemes such as `htTp` or `htTps`, or the bypassing of some requests such as `https` in unencrypted connections. With a fix in versions 1.27.0, 1.26.4, 1.25.9, 1.24.10, and 1.23.12, Envoy will now lowercase scheme values by default, and change the internal scheme checks that were case-sensitive to be case-insensitive. There are no known workarounds for this issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| envoyproxy | envoy | 1.26.0 to before 1.26.4; 1.25.0 to before 1.25.9; 1.24.0 to before 1.24.10; before 1.23.12 | 1.26.4, 1.25.9, 1.24.10, 1.23.12 | Patch available | CNA |
- envoy Vendorenvoyproxy Affected 1.26.0 to before 1.26.4; 1.25.0 to before 1.25.9; 1.24.0 to before 1.24.10; before 1.23.12 Fixed in 1.26.4, 1.25.9, 1.24.10, 1.23.12 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:envoyproxy:envoy:*:*:*:*:*:*:*:* | 1.23.0 to before 1.23.12; 1.24.0 to before 1.24.10; 1.25.0 to before 1.25.9; 1.26.0 to before 1.26.4 | Vulnerable | envoyproxy |
- cpe:2.3:a:envoyproxy:envoy:*:*:*:*:*:*:*:* Versions 1.23.0 to before 1.23.12; 1.24.0 to before 1.24.10; 1.25.0 to before 1.25.9; 1.26.0 to before 1.26.4 Vulnerable ·envoyproxy
Remediation
- Fix · CNA envoy (envoyproxy) Fixed in 1.26.4, 1.25.9, 1.24.10, 1.23.12
Red Hat 3 advisories
- RHSA-2023:5175 Released 2023-09-14 · Red Hat rating ImportantRed Hat OpenShift Service Mesh 2.2.10 security update
- RHOSSM 2.2 for RHEL 8 openshift-service-mesh/proxyv2-rhel8
- RHSA-2023:4625 Released 2023-08-11 · Red Hat rating ImportantRed Hat OpenShift Service Mesh Containers for 2.4.2 security update
- RHOSSM 2.4 for RHEL 8 openshift-service-mesh/proxyv2-rhel8
- RHSA-2023:4624 Released 2023-08-11 · Red Hat rating ImportantRed Hat OpenShift Service Mesh Containers for 2.3.6 security update
- RHOSSM 2.3 for RHEL 8 openshift-service-mesh/proxyv2-rhel8
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| RHOSSM 2.2 for RHEL 8 | Fixed | RHSA-2023:5175 |
| RHOSSM 2.3 for RHEL 8 | Fixed | RHSA-2023:4624 |
| RHOSSM 2.4 for RHEL 8 | Fixed | RHSA-2023:4625 |
Not affected: 3 products
- RHOSSM 2.2 for RHEL 8
- RHOSSM 2.3 for RHEL 8
- RHOSSM 2.4 for RHEL 8
Timeline
- 2026-10-02 Threatist record created from CVE-2023-35944
References
More envoyproxy Envoy vulnerabilities
- TI-2026-79288 Out-of-bounds write in Google Brotli decoder KEVCVSS 4.0CRITICAL 9.2
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2024-20001 HTTP/2: CPU exhaustion due to CONTINUATION frame flood CVSS 3.1HIGH 7.5
- TI-2024-18524 HTTP/2: memory exhaustion due to CONTINUATION frame flood CVSS 3.1HIGH 7.5
- TI-2023-12215 Envoy client may fake the header `x-envoy-original-path` CVSS 3.1CRITICAL 9.1
- TI-2023-18002 Envoy vulnerable to OAuth2 credentials exploit with permanent validity CVSS 3.1CRITICAL 9.8
Sources
- CVE-2023-35944 · CVE Program
- CVE-2023-35944 · NVD
- FIRST EPSS
- CVE-2023-35944 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences