Envoy vulnerable to HTTP/2 memory leak in nghttp2 codec
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat. Impact type from CWE-400.
Summary
Envoy is a cloud-native high-performance edge/middle/service proxy. Envoy’s HTTP/2 codec may leak a header map and bookkeeping structures upon receiving `RST_STREAM` immediately followed by the `GOAWAY` frames from an upstream server. In nghttp2, cleanup of pending requests due to receipt of the `GOAWAY` frame skips de-allocation of the bookkeeping structure and pending compressed header. The error return [code path] is taken if connection is already marked for not sending more requests due to `GOAWAY` frame. The clean-up code is right after the return statement, causing memory leak. Denial of service through memory exhaustion. This vulnerability was patched in versions(s) 1.26.3, 1.25.8, 1.24.9, 1.23.11.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| envoyproxy | envoy | 1.26.0 to before 1.26.3; 1.25.0 to before 1.25.8; 1.24.0 to before 1.24.9; 1.23.0 to before 1.23.11 | 1.26.3, 1.25.8, 1.24.9, 1.23.11 | Patch available | CNA |
- envoy Vendorenvoyproxy Affected 1.26.0 to before 1.26.3; 1.25.0 to before 1.25.8; 1.24.0 to before 1.24.9; 1.23.0 to before 1.23.11 Fixed in 1.26.3, 1.25.8, 1.24.9, 1.23.11 Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:envoyproxy:envoy:*:*:*:*:*:*:*:* | before 1.23.11; 1.24.0 to before 1.24.9; 1.25.0 to before 1.25.8; 1.26.0 to before 1.26.3 | Vulnerable | envoyproxy |
| cpe:2.3:a:nghttp2:nghttp2:*:*:*:*:*:*:*:* | before 1.55.1 | Vulnerable | nghttp2 |
- cpe:2.3:a:envoyproxy:envoy:*:*:*:*:*:*:*:* Versions before 1.23.11; 1.24.0 to before 1.24.9; 1.25.0 to before 1.25.8; 1.26.0 to before 1.26.3 Vulnerable ·envoyproxy
- cpe:2.3:a:nghttp2:nghttp2:*:*:*:*:*:*:*:* Versions before 1.55.1 Vulnerable ·nghttp2
Remediation
- Fix · CNA envoy (envoyproxy) Fixed in 1.26.3, 1.25.8, 1.24.9, 1.23.11
Red Hat 3 advisories
- RHSA-2023:5175 Released 2023-09-14 · Red Hat rating ImportantRed Hat OpenShift Service Mesh 2.2.10 security update
- RHOSSM 2.2 for RHEL 8 openshift-service-mesh/proxyv2-rhel8
- RHSA-2023:4625 Released 2023-08-11 · Red Hat rating ImportantRed Hat OpenShift Service Mesh Containers for 2.4.2 security update
- RHOSSM 2.4 for RHEL 8 openshift-service-mesh/proxyv2-rhel8
- RHSA-2023:4624 Released 2023-08-11 · Red Hat rating ImportantRed Hat OpenShift Service Mesh Containers for 2.3.6 security update
- RHOSSM 2.3 for RHEL 8 openshift-service-mesh/proxyv2-rhel8
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| RHOSSM 2.2 for RHEL 8 | Fixed | RHSA-2023:5175 |
| RHOSSM 2.3 for RHEL 8 | Fixed | RHSA-2023:4624 |
| RHOSSM 2.4 for RHEL 8 | Fixed | RHSA-2023:4625 |
Not affected: 4 products
- RHOSSM 2.2 for RHEL 8
- RHOSSM 2.3 for RHEL 8
- RHOSSM 2.4 for RHEL 8
- Red Hat JBoss Core Services
Timeline
- 2026-10-02 Threatist record created from CVE-2023-35945
References
More envoyproxy Envoy vulnerabilities
- TI-2026-79288 Out-of-bounds write in Google Brotli decoder KEVCVSS 4.0CRITICAL 9.2
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2024-20001 HTTP/2: CPU exhaustion due to CONTINUATION frame flood CVSS 3.1HIGH 7.5
- TI-2024-18524 HTTP/2: memory exhaustion due to CONTINUATION frame flood CVSS 3.1HIGH 7.5
- TI-2023-12215 Envoy client may fake the header `x-envoy-original-path` CVSS 3.1CRITICAL 9.1
- TI-2023-18002 Envoy vulnerable to OAuth2 credentials exploit with permanent validity CVSS 3.1CRITICAL 9.8
Sources
- CVE-2023-35945 · CVE Program
- CVE-2023-35945 · NVD
- FIRST EPSS
- CVE-2023-35945 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences