1Panel vulnerable to ommand injection when entering the container terminal
Priority HIGH 71CWE-77Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-77.
Summary
1Panel is an open source Linux server operation and maintenance management panel. Prior to version 1.3.6, an authenticated attacker can craft a malicious payloads to achieve command injection when entering the container terminal. The vulnerability has been fixed in v1.3.6.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.02313 83rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed github.com/1Panel-dev/1Panel (Go): 1.3.6
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| 1Panel-dev | 1Panel | , 1.3.6 | — | No fix listed | CNA |
| — | github.com/1Panel-dev/1Panel (Go) | before 1.3.6 | 1.3.6 | Patch available | GHSA-7x2c-fgx6-xf9h |
- 1Panel Vendor1Panel-dev Affected , 1.3.6 Fixed in — No fix listed CNA
- github.com/1Panel-dev/1Panel (Go) Vendor— Affected before 1.3.6 Fixed in 1.3.6 Patch available GHSA-7x2c-fgx6-xf9h
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:fit2cloud:1panel:*:*:*:*:*:*:*:* | before 1.3.6 | Vulnerable | 1Panel-dev |
- cpe:2.3:a:fit2cloud:1panel:*:*:*:*:*:*:*:* Versions before 1.3.6 Vulnerable ·1Panel-dev
Remediation
- Fix · GHSA-7x2c-fgx6-xf9h github.com/1Panel-dev/1Panel (Go) Fixed in 1.3.6 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-36458
- 2026-10-03 Alias added: GHSA-7x2c-fgx6-xf9h
References
More 1Panel-dev 1panel vulnerabilities
- TI-2024-26801 a sqlinjection in 1Panel CVSS 3.1CRITICAL 9.8
- TI-2023-20859 1Panel arbitrary file write vulnerability exists in the background CVSS 3.1CRITICAL 9.8
- TI-2025-34229 1Panel Agent Bypasses Certificate Verification Leading to Arbitrary Command Execution CVSS 3.1CRITICAL 9.8
- TI-2024-02187 1Panel swap baseApi.UpdateDeviceSwap command injection CVSS 3.1CRITICAL 9.8
- TI-2025-35333 OS Command injection vulnerability in function OperateSSH in 1panel 2.0.8 allowing… CVSS 3.1HIGH 8.8
- TI-2023-19085 Command injection in firewall ip functionality in 1Panel CVSS 3.1HIGH 8.8
Sources
- CVE-2023-36458 · CVE Program
- CVE-2023-36458 · NVD
- FIRST EPSS
- GHSA-7x2c-fgx6-xf9h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences