Read the docs
TI-2023-18623 Aliases CVE-2023-36829GHSA-4xqm-4p72-87h6

Sentry CORS misconfiguration vulnerability

Priority LOW 33CWE-863Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
High
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-863.

Summary

Sentry is an error tracking and performance monitoring platform. Starting in version 23.6.0 and prior to version 23.6.2, the Sentry API incorrectly returns the `access-control-allow-credentials: true` HTTP header if the `Origin` request header ends with the `system.base-hostname` option of Sentry installation. This only affects installations that have `system.base-hostname` option explicitly set, as it is empty by default. Impact is limited since recent versions of major browsers have cross-site cookie blocking enabled by default. However, this flaw could allow other multi-step attacks. The patch has been released in Sentry 23.6.2.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00666 52nd percentileScored 2026-11-07
Fix Fixed sentry (getsentry): 23.6.2sentry (PyPI): 23.6.2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
getsentrysentry23.6.0 to before 23.6.223.6.2Patch availableCNA
—sentry (PyPI)23.6.0 to before 23.6.223.6.2Patch availableGHSA-4xqm-4p72-87h6
  • sentry Vendorgetsentry Affected 23.6.0 to before 23.6.2 Fixed in 23.6.2 Patch available CNA
  • sentry (PyPI) Vendor— Affected 23.6.0 to before 23.6.2 Fixed in 23.6.2 Patch available GHSA-4xqm-4p72-87h6

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:functional:sentry:*:*:*:*:*:*:*:*23.6.0 to before 23.6.2VulnerableFunctional
  • cpe:2.3:a:functional:sentry:*:*:*:*:*:*:*:* Versions 23.6.0 to before 23.6.2 Vulnerable ·Functional

Remediation

  • Fix · CNA sentry (getsentry) Fixed in 23.6.2
  • Fix · GHSA-4xqm-4p72-87h6 sentry (PyPI) Fixed in 23.6.2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-36829
  2. 2026-10-03 Alias added: GHSA-4xqm-4p72-87h6

References

  • TI-2026-21018 Sentry allows unauthorized access to event data across organizational boundaries CVSS 4.0MEDIUM 5.7
  • TI-2026-30656 Sentry: Improper authentication on SAML SSO process allows user identity linking CVSS 3.1CRITICAL 9.8
  • TI-2026-78982 Sentry-Javascript: Middleware Bypass when using Tunnel route CVSS 4.0CRITICAL 9.1
  • TI-2025-16094 Improper authentication on SAML SSO process allows user impersonation in sentry CVSS 3.1CRITICAL 9.1
  • TI-2023-25212 Sentry Next.js vulnerable to SSRF via Next.js SDK tunnel endpoint CVSS 3.1CRITICAL 9.3
  • TI-2026-21634 Sentry: Improper Authentication on SAML SSO process allows user identity linking CVSS 3.1CRITICAL 9.1
See all 28 →

Sources