Read the docs
TI-2023-18910 Aliases CVE-2023-37280GHSA-hqv9-6jqw-9g8m

Pimcore admin UI vulnerable to Cross-site Scripting in two factor authentication setup page

Priority LOW 28CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Pimcore Admin Classic Bundle provides a Backend UI for Pimcore based on the ExtJS framework. An admin who has not setup two factor authentication before is vulnerable for this attack, without need for any form of privilege, causing the application to execute arbitrary scripts/HTML content. This vulnerability has been patched in version 1.0.3.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00578 47th percentileScored 2026-11-07
Fix Fixed admin-ui-classic-bundle (pimcore): 1.0.3pimcore/admin-ui-classic-bundle (Packagist): 1.0.3

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
pimcoreadmin-ui-classic-bundlebefore 1.0.31.0.3Patch availableCNA
—pimcore/admin-ui-classic-bundle (Packagist)before 1.0.31.0.3Patch availableGHSA-hqv9-6jqw-9g8m
  • admin-ui-classic-bundle Vendorpimcore Affected before 1.0.3 Fixed in 1.0.3 Patch available CNA
  • pimcore/admin-ui-classic-bundle (Packagist) Vendor— Affected before 1.0.3 Fixed in 1.0.3 Patch available GHSA-hqv9-6jqw-9g8m

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:pimcore:admin_classic_bundle:*:*:*:*:*:pimcore:*:*before 1.0.3Vulnerablepimcore
  • cpe:2.3:a:pimcore:admin_classic_bundle:*:*:*:*:*:pimcore:*:* Versions before 1.0.3 Vulnerable ·pimcore

Remediation

  • Fix · CNA admin-ui-classic-bundle (pimcore) Fixed in 1.0.3
  • Fix · GHSA-hqv9-6jqw-9g8m pimcore/admin-ui-classic-bundle (Packagist) Fixed in 1.0.3 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-37280
  2. 2026-10-03 Alias added: GHSA-hqv9-6jqw-9g8m

References

  • TI-2024-15667 Pimcore Admin Classic Bundle host header injection in the password reset CVSS 3.1HIGH 8.8
  • TI-2024-16853 Pimcore Host Header Injection in user invitation link CVSS 3.1CRITICAL 9.3
  • TI-2024-15665 Pimcore Admin Classic Bundle SQL Injection in Admin download files as zip CVSS 3.1HIGH 8.8
  • TI-2025-18658 Pimcore Admin Classic Bundle allows user enumeration CVSS 4.0MEDIUM 6.9
  • TI-2023-05380 Unverified Password Change in pimcore/admin-ui-classic-bundle CVSS 3.1HIGH 7.2
  • TI-2023-25777 Full Path Disclosure via re-export document in pimcore/admin-ui-classic-bundle CVSS 3.1MEDIUM 5.3
See all 13 →

Sources