Apache Airflow: Exposure of sensitive connection information, DOS and SSRF on "test connection" feature
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure, Denial of service
- Confidentiality · integrity · availability
- High · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200 and CWE-400.
Summary
Apache Airflow, in versions prior to 2.7.0, contains a security vulnerability that can be exploited by an authenticated user possessing Connection edit privileges. This vulnerability allows the user to access connection information and exploit the test connection feature by sending many requests, leading to a denial of service (DoS) condition on the server. Furthermore, malicious actors can leverage this vulnerability to establish harmful connections with the server. Users of Apache Airflow are strongly advised to upgrade to version 2.7.0 or newer to mitigate the risk associated with this vulnerability. Additionally, administrators are encouraged to review and adjust user permissions to restrict access to sensitive functionalities, reducing the attack surface.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Airflow | before 2.7.0 | 2.7.0 | Patch available | CNA |
| — | apache-airflow (PyPI) | before 2.7.0b1 | 2.7.0b1 | Patch available | GHSA-x2mh-8fmc-rqgh |
- Apache Airflow VendorApache Affected before 2.7.0 Fixed in 2.7.0 Patch available CNA
- apache-airflow (PyPI) Vendor— Affected before 2.7.0b1 Fixed in 2.7.0b1 Patch available GHSA-x2mh-8fmc-rqgh
Remediation
- Fix · CNA Apache Airflow (Apache Software Foundation) Fixed in 2.7.0
- Fix · GHSA-x2mh-8fmc-rqgh apache-airflow (PyPI) Fixed in 2.7.0b1 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Apache Airflow 2.7.0
3 records Highest priority Priority MEDIUM 1 MEDIUM, 2 LOW
Other records, highest priority first
- TI-2023-21115 Session fixation in Apache Airflow web interfacePriority MEDIUM 41
- TI-2023-20577 Improper certificate validation in Apache Airflow SMTP ProviderPriority LOW 28
Timeline
- 2026-10-02 Threatist record created from CVE-2023-37379
- 2026-10-03 Alias added: GHSA-x2mh-8fmc-rqgh
References
Advisory 3
More Apache Airflow vulnerabilities
- TI-2020-10905 Missing authentication in Apache Airflow KEVCVSS 3.1CRITICAL 9.8
- TI-2020-09638 OS command injection in Apache Airflow KEVCVSS 3.1HIGH 8.8
- TI-2022-19017 Apache Airflow <2.4.0 has an RCE in a bash example CVSS 3.1HIGH 8.8
- TI-2021-16140 Apache Airflow: Variable Import endpoint missed authentication check CVSS 3.1CRITICAL 9.8
- TI-2022-08169 Apache Airflow: RCE in example DAGs CVSS 3.1HIGH 8.8
- TI-2024-26776 Apache Airflow: DAG Author Code Execution possibility in airflow-scheduler CVSS 3.1HIGH 8.8
Sources
- CVE-2023-37379 · CVE Program
- CVE-2023-37379 · NVD
- FIRST EPSS
- GHSA-x2mh-8fmc-rqgh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences