Session fixation in Apache Airflow web interface
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-384.
Summary
The session fixation vulnerability allowed the authenticated user to continue accessing Airflow webserver even after the password of the user has been reset by the admin - up until the expiry of the session of the user. Other than manually cleaning the session database (for database session backend), or changing the secure_key and restarting the webserver, there were no mechanisms to force-logout the user (and all other users with that). With this fix implemented, when using the database session backend, the existing sessions of the user are invalidated when the password of the user is reset. When using the securecookie session backend, the sessions are NOT invalidated and still require changing the secure key and restarting the webserver (and logging out all other users), but the user resetting the password is informed about it with a flash message warning displayed in the UI. Documentation is also updated explaining this behaviour. Users of Apache Airflow are advised to upgrade to version 2.7.0 or newer to mitigate the risk associated with this vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Airflow | before 2.7.0 | 2.7.0 | Patch available | CNA |
| — | apache-airflow (PyPI) | before 2.7.0rc2 | 2.7.0rc2 | Patch available | GHSA-pm87-24wq-r8w9 |
- Apache Airflow VendorApache Affected before 2.7.0 Fixed in 2.7.0 Patch available CNA
- apache-airflow (PyPI) Vendor— Affected before 2.7.0rc2 Fixed in 2.7.0rc2 Patch available GHSA-pm87-24wq-r8w9
Remediation
- Fix · CNA Apache Airflow (Apache Software Foundation) Fixed in 2.7.0
- Fix · GHSA-pm87-24wq-r8w9 apache-airflow (PyPI) Fixed in 2.7.0rc2 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Apache Airflow 2.7.0
3 records Highest priority Priority MEDIUM 1 MEDIUM, 2 LOW
Other records, highest priority first
- TI-2023-19005 Apache Airflow: Exposure of sensitive connection information, DOS and SSRF on "test connection" featurePriority LOW 39
- TI-2023-20577 Improper certificate validation in Apache Airflow SMTP ProviderPriority LOW 28
Timeline
- 2026-10-02 Threatist record created from CVE-2023-40273
- 2026-10-03 Alias added: GHSA-pm87-24wq-r8w9
References
Advisory 3
More Apache Airflow vulnerabilities
- TI-2020-10905 Missing authentication in Apache Airflow KEVCVSS 3.1CRITICAL 9.8
- TI-2020-09638 OS command injection in Apache Airflow KEVCVSS 3.1HIGH 8.8
- TI-2022-19017 Apache Airflow <2.4.0 has an RCE in a bash example CVSS 3.1HIGH 8.8
- TI-2021-16140 Apache Airflow: Variable Import endpoint missed authentication check CVSS 3.1CRITICAL 9.8
- TI-2022-08169 Apache Airflow: RCE in example DAGs CVSS 3.1HIGH 8.8
- TI-2024-26776 Apache Airflow: DAG Author Code Execution possibility in airflow-scheduler CVSS 3.1HIGH 8.8
Sources
- CVE-2023-40273 · CVE Program
- CVE-2023-40273 · NVD
- FIRST EPSS
- GHSA-pm87-24wq-r8w9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences