Adobe Commerce XML Injection (aka Blind XPath Injection) Arbitrary file system read
Priority MEDIUM 41CWE-91Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
Adobe Commerce versions 2.4.6-p1 (and earlier), 2.4.5-p3 (and earlier) and 2.4.4-p4 (and earlier) are affected by a XML Injection (aka Blind XPath Injection) vulnerability that could lead in minor arbitrary file system read. Exploitation of this issue does not require user interaction.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01069 65th percentileScored 2026-11-07
Fix Fixed magento/community-edition (Packagist): 2.4.6-p2, 2.4.5-p4, 2.4.4-p5
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Adobe | Adobe Commerce | up to 2.4.4-p4 | — | No fix listed | CNA |
| — | magento/community-edition (Packagist) | — | — | No fix listed | GHSA-rpv2-g4pc-wp72 |
| — | magento/community-edition (Packagist) | — | — | No fix listed | GHSA-rpv2-g4pc-wp72 |
| — | magento/community-edition (Packagist) | — | — | No fix listed | GHSA-rpv2-g4pc-wp72 |
| — | magento/community-edition (Packagist) | 2.4.6-p1 to before 2.4.6-p2 | 2.4.6-p2 | Patch available | GHSA-rpv2-g4pc-wp72 |
| — | magento/community-edition (Packagist) | 2.4.5-p1 to before 2.4.5-p4 | 2.4.5-p4 | Patch available | GHSA-rpv2-g4pc-wp72 |
| — | magento/community-edition (Packagist) | 2.4.4-p1 to before 2.4.4-p5 | 2.4.4-p5 | Patch available | GHSA-rpv2-g4pc-wp72 |
| — | magento/project-community-edition (Packagist) | up to 2.0.2 | — | No fix listed | GHSA-rpv2-g4pc-wp72 |
- Adobe Commerce VendorAdobe Affected up to 2.4.4-p4 Fixed in — No fix listed CNA
- magento/community-edition (Packagist) Vendor— Affected — Fixed in — No fix listed GHSA-rpv2-g4pc-wp72
- magento/community-edition (Packagist) Vendor— Affected — Fixed in — No fix listed GHSA-rpv2-g4pc-wp72
- magento/community-edition (Packagist) Vendor— Affected — Fixed in — No fix listed GHSA-rpv2-g4pc-wp72
- magento/community-edition (Packagist) Vendor— Affected 2.4.6-p1 to before 2.4.6-p2 Fixed in 2.4.6-p2 Patch available GHSA-rpv2-g4pc-wp72
- magento/community-edition (Packagist) Vendor— Affected 2.4.5-p1 to before 2.4.5-p4 Fixed in 2.4.5-p4 Patch available GHSA-rpv2-g4pc-wp72
- magento/community-edition (Packagist) Vendor— Affected 2.4.4-p1 to before 2.4.4-p5 Fixed in 2.4.4-p5 Patch available GHSA-rpv2-g4pc-wp72
- magento/project-community-edition (Packagist) Vendor— Affected up to 2.0.2 Fixed in — No fix listed GHSA-rpv2-g4pc-wp72
CPE configurations NVD · 12
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:adobe:commerce:*:*:*:*:*:*:*:* | before 2.4.4 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:commerce:2.4.4:-:*:*:*:*:*:* | 2.4.4 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:commerce:2.4.4:p1:*:*:*:*:*:* | 2.4.4 p1 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:commerce:2.4.4:p2:*:*:*:*:*:* | 2.4.4 p2 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:commerce:2.4.4:p3:*:*:*:*:*:* | 2.4.4 p3 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:commerce:2.4.4:p4:*:*:*:*:*:* | 2.4.4 p4 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:commerce:2.4.5:-:*:*:*:*:*:* | 2.4.5 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:commerce:2.4.5:p1:*:*:*:*:*:* | 2.4.5 p1 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:commerce:2.4.5:p2:*:*:*:*:*:* | 2.4.5 p2 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:commerce:2.4.5:p3:*:*:*:*:*:* | 2.4.5 p3 | Vulnerable | Adobe |
- cpe:2.3:a:adobe:commerce:*:*:*:*:*:*:*:* Versions before 2.4.4 Vulnerable ·Adobe
- cpe:2.3:a:adobe:commerce:2.4.4:-:*:*:*:*:*:* Versions 2.4.4 Vulnerable ·Adobe
- cpe:2.3:a:adobe:commerce:2.4.4:p1:*:*:*:*:*:* Versions 2.4.4 p1 Vulnerable ·Adobe
- cpe:2.3:a:adobe:commerce:2.4.4:p2:*:*:*:*:*:* Versions 2.4.4 p2 Vulnerable ·Adobe
- cpe:2.3:a:adobe:commerce:2.4.4:p3:*:*:*:*:*:* Versions 2.4.4 p3 Vulnerable ·Adobe
- cpe:2.3:a:adobe:commerce:2.4.4:p4:*:*:*:*:*:* Versions 2.4.4 p4 Vulnerable ·Adobe
- cpe:2.3:a:adobe:commerce:2.4.5:-:*:*:*:*:*:* Versions 2.4.5 Vulnerable ·Adobe
- cpe:2.3:a:adobe:commerce:2.4.5:p1:*:*:*:*:*:* Versions 2.4.5 p1 Vulnerable ·Adobe
- cpe:2.3:a:adobe:commerce:2.4.5:p2:*:*:*:*:*:* Versions 2.4.5 p2 Vulnerable ·Adobe
- cpe:2.3:a:adobe:commerce:2.4.5:p3:*:*:*:*:*:* Versions 2.4.5 p3 Vulnerable ·Adobe
Remediation
- Fix · GHSA-rpv2-g4pc-wp72 magento/community-edition (Packagist) Fixed in 2.4.6-p2 Advisory →
- Fix · GHSA-rpv2-g4pc-wp72 magento/community-edition (Packagist) Fixed in 2.4.5-p4 Advisory →
- Fix · GHSA-rpv2-g4pc-wp72 magento/community-edition (Packagist) Fixed in 2.4.4-p5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-38207
- 2026-10-03 Alias added: GHSA-rpv2-g4pc-wp72
References
More Adobe Commerce vulnerabilities
- TI-2026-52938 Adobe Commerce | Improper Neutralization of Special Elements Used in a Template Engine (CWE-1336) KEVCVSS 3.1CRITICAL 10.0
- TI-2024-22559 XXE can expose crypt key and other secrets granting full admin access KEVCVSS 3.1CRITICAL 9.8
- TI-2022-08035 Adobe Commerce checkout improper input validation leads to remote code execution KEVCVSS 3.1CRITICAL 9.8
- TI-2026-35762 Unrestricted file upload in Adobe Commerce allows code execution KEVCVSS 3.1CRITICAL 9.3
- TI-2026-50010 Adobe Commerce | Incorrect Authorization (CWE-863) KEVCVSS 3.1CRITICAL 9.1
- TI-2025-34067 Adobe Commerce | Improper Input Validation (CWE-20) KEVCVSS 3.1CRITICAL 9.1
Sources
- CVE-2023-38207 · CVE Program
- CVE-2023-38207 · NVD
- FIRST EPSS
- GHSA-rpv2-g4pc-wp72 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences