Read the docs
TI-2023-19621 Aliases CVE-2023-38209GHSA-3vg2-v639-6ch9

Adobe Commerce Incorrect Authorization Security feature bypass

Priority LOW 31CWE-863Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-863.

Summary

Adobe Commerce versions 2.4.6-p1 (and earlier), 2.4.5-p3 (and earlier) and 2.4.4-p4 (and earlier) are affected by an Incorrect Authorization vulnerability that could lead to a Security feature bypass. A low-privileged attacker could leverage this vulnerability to access other user's data. Exploitation of this issue does not require user interaction.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00973 62nd percentileScored 2026-11-07
Fix Fixed magento/community-edition (Packagist): 2.4.6-p2, 2.4.5-p4, 2.4.4-p5

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
AdobeMagento Commerceup to 2.4.4-p4—No fix listedCNA
—magento/community-edition (Packagist)——No fix listedGHSA-3vg2-v639-6ch9
—magento/community-edition (Packagist)——No fix listedGHSA-3vg2-v639-6ch9
—magento/community-edition (Packagist)——No fix listedGHSA-3vg2-v639-6ch9
—magento/community-edition (Packagist)2.4.6-p1 to before 2.4.6-p22.4.6-p2Patch availableGHSA-3vg2-v639-6ch9
—magento/community-edition (Packagist)2.4.5-p1 to before 2.4.5-p42.4.5-p4Patch availableGHSA-3vg2-v639-6ch9
—magento/community-edition (Packagist)2.4.4-p1 to before 2.4.4-p52.4.4-p5Patch availableGHSA-3vg2-v639-6ch9
—magento/project-community-edition (Packagist)up to 2.0.2—No fix listedGHSA-3vg2-v639-6ch9
  • Magento Commerce VendorAdobe Affected up to 2.4.4-p4 Fixed in — No fix listed CNA
  • magento/community-edition (Packagist) Vendor— Affected — Fixed in — No fix listed GHSA-3vg2-v639-6ch9
  • magento/community-edition (Packagist) Vendor— Affected — Fixed in — No fix listed GHSA-3vg2-v639-6ch9
  • magento/community-edition (Packagist) Vendor— Affected — Fixed in — No fix listed GHSA-3vg2-v639-6ch9
  • magento/community-edition (Packagist) Vendor— Affected 2.4.6-p1 to before 2.4.6-p2 Fixed in 2.4.6-p2 Patch available GHSA-3vg2-v639-6ch9
  • magento/community-edition (Packagist) Vendor— Affected 2.4.5-p1 to before 2.4.5-p4 Fixed in 2.4.5-p4 Patch available GHSA-3vg2-v639-6ch9
  • magento/community-edition (Packagist) Vendor— Affected 2.4.4-p1 to before 2.4.4-p5 Fixed in 2.4.4-p5 Patch available GHSA-3vg2-v639-6ch9
  • magento/project-community-edition (Packagist) Vendor— Affected up to 2.0.2 Fixed in — No fix listed GHSA-3vg2-v639-6ch9

CPE configurations NVD · 12

CPEVersionsRoleVendor
cpe:2.3:a:adobe:commerce:*:*:*:*:*:*:*:*before 2.4.4VulnerableAdobe
cpe:2.3:a:adobe:commerce:2.4.4:-:*:*:*:*:*:*2.4.4VulnerableAdobe
cpe:2.3:a:adobe:commerce:2.4.4:p1:*:*:*:*:*:*2.4.4 p1VulnerableAdobe
cpe:2.3:a:adobe:commerce:2.4.4:p2:*:*:*:*:*:*2.4.4 p2VulnerableAdobe
cpe:2.3:a:adobe:commerce:2.4.4:p3:*:*:*:*:*:*2.4.4 p3VulnerableAdobe
cpe:2.3:a:adobe:commerce:2.4.4:p4:*:*:*:*:*:*2.4.4 p4VulnerableAdobe
cpe:2.3:a:adobe:commerce:2.4.5:-:*:*:*:*:*:*2.4.5VulnerableAdobe
cpe:2.3:a:adobe:commerce:2.4.5:p1:*:*:*:*:*:*2.4.5 p1VulnerableAdobe
cpe:2.3:a:adobe:commerce:2.4.5:p2:*:*:*:*:*:*2.4.5 p2VulnerableAdobe
cpe:2.3:a:adobe:commerce:2.4.5:p3:*:*:*:*:*:*2.4.5 p3VulnerableAdobe
  • cpe:2.3:a:adobe:commerce:*:*:*:*:*:*:*:* Versions before 2.4.4 Vulnerable ·Adobe
  • cpe:2.3:a:adobe:commerce:2.4.4:-:*:*:*:*:*:* Versions 2.4.4 Vulnerable ·Adobe
  • cpe:2.3:a:adobe:commerce:2.4.4:p1:*:*:*:*:*:* Versions 2.4.4 p1 Vulnerable ·Adobe
  • cpe:2.3:a:adobe:commerce:2.4.4:p2:*:*:*:*:*:* Versions 2.4.4 p2 Vulnerable ·Adobe
  • cpe:2.3:a:adobe:commerce:2.4.4:p3:*:*:*:*:*:* Versions 2.4.4 p3 Vulnerable ·Adobe
  • cpe:2.3:a:adobe:commerce:2.4.4:p4:*:*:*:*:*:* Versions 2.4.4 p4 Vulnerable ·Adobe
  • cpe:2.3:a:adobe:commerce:2.4.5:-:*:*:*:*:*:* Versions 2.4.5 Vulnerable ·Adobe
  • cpe:2.3:a:adobe:commerce:2.4.5:p1:*:*:*:*:*:* Versions 2.4.5 p1 Vulnerable ·Adobe
  • cpe:2.3:a:adobe:commerce:2.4.5:p2:*:*:*:*:*:* Versions 2.4.5 p2 Vulnerable ·Adobe
  • cpe:2.3:a:adobe:commerce:2.4.5:p3:*:*:*:*:*:* Versions 2.4.5 p3 Vulnerable ·Adobe
Show 2 more CPE
CPEVersionsRoleVendor
cpe:2.3:a:adobe:commerce:2.4.6:-:*:*:*:*:*:*2.4.6VulnerableAdobe
cpe:2.3:a:adobe:commerce:2.4.6:p1:*:*:*:*:*:*2.4.6 p1VulnerableAdobe
  • cpe:2.3:a:adobe:commerce:2.4.6:-:*:*:*:*:*:* Versions 2.4.6 Vulnerable ·Adobe
  • cpe:2.3:a:adobe:commerce:2.4.6:p1:*:*:*:*:*:* Versions 2.4.6 p1 Vulnerable ·Adobe

Remediation

  • Fix · GHSA-3vg2-v639-6ch9 magento/community-edition (Packagist) Fixed in 2.4.6-p2 Advisory →
  • Fix · GHSA-3vg2-v639-6ch9 magento/community-edition (Packagist) Fixed in 2.4.5-p4 Advisory →
  • Fix · GHSA-3vg2-v639-6ch9 magento/community-edition (Packagist) Fixed in 2.4.4-p5 Advisory →

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Advisory ·

    Adobe Magento Commerce — helpx.adobe.com/security/products/magento/apsb23-42.html

    2 records Highest priority Priority MEDIUM 1 MEDIUM, 1 LOW

    Other records, highest priority first

    • TI-2023-19620 OS command injection in Adobe Magento CommercePriority MEDIUM 46

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-38209
  2. 2026-10-03 Alias added: GHSA-3vg2-v639-6ch9

References

  • TI-2026-52938 Adobe Commerce | Improper Neutralization of Special Elements Used in a Template Engine (CWE-1336) KEVCVSS 3.1CRITICAL 10.0
  • TI-2024-22559 XXE can expose crypt key and other secrets granting full admin access KEVCVSS 3.1CRITICAL 9.8
  • TI-2022-08035 Adobe Commerce checkout improper input validation leads to remote code execution KEVCVSS 3.1CRITICAL 9.8
  • TI-2026-35762 Unrestricted file upload in Adobe Commerce allows code execution KEVCVSS 3.1CRITICAL 9.3
  • TI-2026-50010 Adobe Commerce | Incorrect Authorization (CWE-863) KEVCVSS 3.1CRITICAL 9.1
  • TI-2025-34067 Adobe Commerce | Improper Input Validation (CWE-20) KEVCVSS 3.1CRITICAL 9.1
See all 213 →

Sources