Read the docs
TI-2023-19875 Aliases CVE-2023-38495GHSA-pj4x-2xr5-w87m

Crossplane vulnerable to possible image tampering from missing image validation for Packages

Priority MEDIUM 44CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.

Summary

Crossplane is a framework for building cloud native control planes without needing to write code. In versions prior to 1.11.5, 1.12.3, and 1.13.0, Crossplane's image backend does not validate the byte contents of Crossplane packages. As such, Crossplane does not detect if an attacker has tampered with a Package. The problem has been fixed in 1.11.5, 1.12.3 and 1.13.0. As a workaround, only use images from trusted sources and keep Package editing/creating privileges to administrators only.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00836 57th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed crossplane (crossplane): 1.11.5, 1.12.3github.com/crossplane/crossplane (Go): 1.11.5, 1.12.3

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
crossplanecrossplanebefore 1.11.5; 1.12.0 to before 1.12.31.11.5, 1.12.3Patch availableCNA
—github.com/crossplane/crossplane (Go)before 1.11.51.11.5Patch availableGHSA-pj4x-2xr5-w87m
—github.com/crossplane/crossplane (Go)1.12.0 to before 1.12.31.12.3Patch availableGHSA-pj4x-2xr5-w87m
  • crossplane Vendorcrossplane Affected before 1.11.5; 1.12.0 to before 1.12.3 Fixed in 1.11.5, 1.12.3 Patch available CNA
  • github.com/crossplane/crossplane (Go) Vendor— Affected before 1.11.5 Fixed in 1.11.5 Patch available GHSA-pj4x-2xr5-w87m
  • github.com/crossplane/crossplane (Go) Vendor— Affected 1.12.0 to before 1.12.3 Fixed in 1.12.3 Patch available GHSA-pj4x-2xr5-w87m

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:cncf:crossplane:*:*:*:*:*:*:*:*before 1.11.5; 1.12.0 to before 1.12.3VulnerableCncf
  • cpe:2.3:a:cncf:crossplane:*:*:*:*:*:*:*:* Versions before 1.11.5; 1.12.0 to before 1.12.3 Vulnerable ·Cncf

Remediation

  • Fix · CNA crossplane (crossplane) Fixed in 1.11.5, 1.12.3
  • Fix · GHSA-pj4x-2xr5-w87m github.com/crossplane/crossplane (Go) Fixed in 1.11.5 Advisory →
  • Fix · GHSA-pj4x-2xr5-w87m github.com/crossplane/crossplane (Go) Fixed in 1.12.3 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-38495
  2. 2026-10-03 Alias added: GHSA-pj4x-2xr5-w87m

References

  • TI-2026-67558 crossplane crossplane-runtime ImageConfig client.go Get toctou CVSS 4.0MEDIUM 6.9
  • TI-2023-12211 fieldpath's Paved.SetValue allows growing arrays up to arbitrary sizes in crossplane-runtime CVSS 3.1HIGH 7.5
  • TI-2023-12212 Unchecked fieldpath index in Composition's patches can lead to arbitrary memory allocation in crossplane CVSS 3.1MEDIUM 6.2
  • TI-2023-19333 Crossplane vulnerable to denial of service from large image CVSS 3.1LOW 3.4

Sources