Code injection in NodeJS Node
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Partial Red Hat: 2 fixed, 3 without a fix
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and Red Hat. Impact type from CWE-94.
Summary
Maliciously crafted export names in an imported WebAssembly module can inject JavaScript code. The injected code may be able to access data and functions that the WebAssembly module itself does not have access to, similar to as if the WebAssembly module was a JavaScript module. This vulnerability affects users of any active release line of Node.js. The vulnerable feature is only available if Node.js is started with the `--experimental-wasm-modules` command line option.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| NodeJS | Node | 4.0 and later; 5.0 and later; 6.0 and later; 7.0 and later; 8.0 and later; 9.0 and later; 10.0 and later; 11.0 and later; 12.0 and later; 13.0 and later; 14.0 and later; 15.0 and later; 16.0 and later; 17.0 and later; 18.0 to before 18.18.2; 19.0 and later; 20.0 to before 20.8.1 | 18.18.2, 20.8.1 | Patch available | CNA |
- Node VendorNodeJS Affected 4.0 and later; 5.0 and later; 6.0 and later; 7.0 and later; 8.0 and later; 9.0 and later; 10.0 and later; 11.0 and later; 12.0 and later; 13.0 and later; 14.0 and later; 15.0 and later; 16.0 and later; 17.0 and later; 18.0 to before 18.18.2; 19.0 and later; 20.0 to before 20.8.1 Fixed in 18.18.2, 20.8.1 Patch available CNA
Remediation
- Fix · CNA Node (NodeJS) Fixed in 18.18.2, 20.8.1
Red Hat 3 advisories
- RHSA-2023:7205 Released 2023-11-14 · Red Hat rating Importantnodejs:20 security update
- Red Hat Enterprise Linux AppStream (v. 8) nodejs-1:20.8.1-1.module+el8.9.0+20473+c4e3d824.aarch64::nodejs:20, nodejs-1:20.8.1-1.module+el8.9.0+20473+c4e3d824.ppc64le::nodejs:20, nodejs-1:20.8.1-1.module+el8.9.0+20473+c4e3d824.s390x::nodejs:20 +20
- RHSA-2023:5869 Released 2023-10-18 · Red Hat rating Importantnodejs:18 security update
- Red Hat Enterprise Linux AppStream (v. 8) nodejs-1:18.18.2-1.module+el8.8.0+20407+c11d40bd.aarch64::nodejs:18, nodejs-1:18.18.2-1.module+el8.8.0+20407+c11d40bd.ppc64le::nodejs:18, nodejs-1:18.18.2-1.module+el8.8.0+20407+c11d40bd.s390x::nodejs:18 +20
- RHSA-2023:5849 Released 2023-10-18 · Red Hat rating Importantnodejs:18 security update
- Red Hat Enterprise Linux AppStream (v. 9) nodejs-1:18.18.2-2.module+el9.2.0.z+20408+7cb5fda5.aarch64::nodejs:18, nodejs-1:18.18.2-2.module+el9.2.0.z+20408+7cb5fda5.ppc64le::nodejs:18, nodejs-1:18.18.2-2.module+el9.2.0.z+20408+7cb5fda5.s390x::nodejs:18 +20
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 8 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 9 | Affected | No fix yet: Fix deferred |
| Red Hat Software Collections | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux AppStream (v. 8) | Fixed | RHSA-2023:5869, RHSA-2023:7205 |
| Red Hat Enterprise Linux AppStream (v. 9) | Fixed | RHSA-2023:5849 |
Not affected: 1 product
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2023-39333
- 2026-10-03 Alias added: GHSA-wj24-gwh6-mgh8
More NodeJS vulnerabilities
- TI-2026-79288 Out-of-bounds write in Google Brotli decoder KEVCVSS 4.0CRITICAL 9.2
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2024-18584 Race condition in NodeJS Node CVSS 3.0HIGH 8.2
- TI-2016-01993 The DES and Triple DES ciphers, as used in the TLS, SSH, and IPSec protocols and other… CVSS 3.1HIGH 7.5
- TI-2024-03325 Command injection vulnerability in programing languages on Microsoft Windows operating system. CVSS 3.1CRITICAL 9.8
- TI-2022-03472 X.509 Email Address Variable Length Buffer Overflow CVSS 3.1HIGH 7.5
Sources
- CVE-2023-39333 · CVE Program
- CVE-2023-39333 · NVD
- FIRST EPSS
- GHSA-wj24-gwh6-mgh8 · GitHub Advisory Database · CC BY 4.0
- CVE-2023-39333 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences