Sentry vulnerable to incorrect credential validation on OAuth token requests
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-287.
Summary
Sentry is an error tracking and performance monitoring platform. Starting in version 10.0.0 and prior to version 23.7.2, an attacker with sufficient client-side exploits could retrieve a valid access token for another user during the OAuth token exchange due to incorrect credential validation. The client ID must be known and the API application must have already been authorized on the targeted user account. Sentry SaaS customers do not need to take any action. Self-hosted installations should upgrade to version 23.7.2 or higher. There are no direct workarounds, but users should review applications authorized on their account and remove any that are no longer needed.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| getsentry | sentry | 10.0.0 to before 23.7.2 | 23.7.2 | Patch available | CNA |
| — | sentry (PyPI) | 10.0.0 to before 23.7.2 | 23.7.2 | Patch available | GHSA-hgj4-h2x3-rfx4 |
- sentry Vendorgetsentry Affected 10.0.0 to before 23.7.2 Fixed in 23.7.2 Patch available CNA
- sentry (PyPI) Vendor— Affected 10.0.0 to before 23.7.2 Fixed in 23.7.2 Patch available GHSA-hgj4-h2x3-rfx4
Remediation
- Fix · CNA sentry (getsentry) Fixed in 23.7.2
- Fix · GHSA-hgj4-h2x3-rfx4 sentry (PyPI) Fixed in 23.7.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-39531
- 2026-10-03 Alias added: GHSA-hgj4-h2x3-rfx4
References
More getsentry vulnerabilities
- TI-2026-21018 Sentry allows unauthorized access to event data across organizational boundaries CVSS 4.0MEDIUM 5.7
- TI-2026-30656 Sentry: Improper authentication on SAML SSO process allows user identity linking CVSS 3.1CRITICAL 9.8
- TI-2026-78982 Sentry-Javascript: Middleware Bypass when using Tunnel route CVSS 4.0CRITICAL 9.1
- TI-2025-16094 Improper authentication on SAML SSO process allows user impersonation in sentry CVSS 3.1CRITICAL 9.1
- TI-2023-25212 Sentry Next.js vulnerable to SSRF via Next.js SDK tunnel endpoint CVSS 3.1CRITICAL 9.3
- TI-2026-21634 Sentry: Improper Authentication on SAML SSO process allows user identity linking CVSS 3.1CRITICAL 9.1
Sources
- CVE-2023-39531 · CVE Program
- CVE-2023-39531 · NVD
- FIRST EPSS
- GHSA-hgj4-h2x3-rfx4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences