SES's dynamic import and spread operator provides possible path to arbitrary exfiltration and execution
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
SES is a JavaScript environment that allows safe execution of arbitrary programs in Compartments. In version 0.18.0 prior to 0.18.7, 0.17.0 prior to 0.17.1, 0.16.0 prior to 0.16.1, 0.15.0 prior to 0.15.24, 0.14.0 prior to 0.14.5, an 0.13.0 prior to 0.13.5, there is a hole in the confinement of guest applications under SES that may manifest as either the ability to exfiltrate information or execute arbitrary code depending on the configuration and implementation of the surrounding host. Guest program running inside a Compartment with as few as no endowments can gain access to the surrounding host’s dynamic import by using dynamic import after the spread operator, like `{...import(arbitraryModuleSpecifier)}`. On the web or in web extensions, a Content-Security-Policy following ordinary best practices likely mitigates both the risk of exfiltration and execution of arbitrary code, at least limiting the modules that the attacker can import to those that are already part of the application. However, without a Content-Security-Policy, dynamic import can be used to issue HTTP requests for either communication through the URL or for the execution of code reachable from that origin. Within an XS worker, an attacker can use the host’s module system to the extent that the host has been configured. This typically only allows access to module code on the host’s file system and is of limited use to an attacker. Within Node.js, the attacker gains access to Node.js’s module system. Importing the powerful builtins is not useful except insofar as there are side-effects and tempered because dynamic import returns a promise. Spreading a promise into an object renders the promises useless. However, Node.js allows importing data URLs, so this is a clear path to arbitrary execution. Versions 0.18.7, 0.17.1, 0.16.1, 0.15.24, 0.14.5, and 0.13.5 contain a patch for this issue. Some workarounds are available. On the web, providing a suitably constrained Content-Security-Policy mitigates most of the threat. With XS, building a binary that lacks the ability to load modules at runtime mitigates the entirety of the threat. That will look like an implementation of `fxFindModule` in a file like `xsPlatform.c` that calls `fxRejectModuleFile`.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| endojs | endo | 0.18.0 to before 0.18.7; = 0.17.0; = 0.16.0; 0.15.0 to before 0.15.24; 0.14.0 to before 0.14.5; 0.13.0 to before 0.13.5 | 0.18.7, 0.15.24, 0.14.5, 0.13.5 | Patch available | CNA |
| — | ses (npm) | 0.13.0 to before 0.13.5 | 0.13.5 | Patch available | GHSA-9c4h-3f7h-322r |
| — | ses (npm) | 0.14.0 to before 0.14.5 | 0.14.5 | Patch available | GHSA-9c4h-3f7h-322r |
| — | ses (npm) | 0.15.0 to before 0.15.24 | 0.15.24 | Patch available | GHSA-9c4h-3f7h-322r |
| — | ses (npm) | 0.16.0 to before 0.16.1 | 0.16.1 | Patch available | GHSA-9c4h-3f7h-322r |
| — | ses (npm) | 0.17.0 to before 0.17.1 | 0.17.1 | Patch available | GHSA-9c4h-3f7h-322r |
| — | ses (npm) | 0.18.0 to before 0.18.7 | 0.18.7 | Patch available | GHSA-9c4h-3f7h-322r |
- endo Vendorendojs Affected 0.18.0 to before 0.18.7; = 0.17.0; = 0.16.0; 0.15.0 to before 0.15.24; 0.14.0 to before 0.14.5; 0.13.0 to before 0.13.5 Fixed in 0.18.7, 0.15.24, 0.14.5, 0.13.5 Patch available CNA
- ses (npm) Vendor— Affected 0.13.0 to before 0.13.5 Fixed in 0.13.5 Patch available GHSA-9c4h-3f7h-322r
- ses (npm) Vendor— Affected 0.14.0 to before 0.14.5 Fixed in 0.14.5 Patch available GHSA-9c4h-3f7h-322r
- ses (npm) Vendor— Affected 0.15.0 to before 0.15.24 Fixed in 0.15.24 Patch available GHSA-9c4h-3f7h-322r
- ses (npm) Vendor— Affected 0.16.0 to before 0.16.1 Fixed in 0.16.1 Patch available GHSA-9c4h-3f7h-322r
- ses (npm) Vendor— Affected 0.17.0 to before 0.17.1 Fixed in 0.17.1 Patch available GHSA-9c4h-3f7h-322r
- ses (npm) Vendor— Affected 0.18.0 to before 0.18.7 Fixed in 0.18.7 Patch available GHSA-9c4h-3f7h-322r
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:agoric:ses:*:*:*:*:*:node.js:*:* | 0.13.0 to before 0.13.5; 0.14.0 to before 0.14.5; 0.15.0 to before 0.15.24; 0.18.0 to before 0.18.7 | Vulnerable | Agoric |
| cpe:2.3:a:agoric:ses:0.16.0:*:*:*:*:node.js:*:* | 0.16.0 | Vulnerable | Agoric |
| cpe:2.3:a:agoric:ses:0.17.0:*:*:*:*:node.js:*:* | 0.17.0 | Vulnerable | Agoric |
- cpe:2.3:a:agoric:ses:*:*:*:*:*:node.js:*:* Versions 0.13.0 to before 0.13.5; 0.14.0 to before 0.14.5; 0.15.0 to before 0.15.24; 0.18.0 to before 0.18.7 Vulnerable ·Agoric
- cpe:2.3:a:agoric:ses:0.16.0:*:*:*:*:node.js:*:* Versions 0.16.0 Vulnerable ·Agoric
- cpe:2.3:a:agoric:ses:0.17.0:*:*:*:*:node.js:*:* Versions 0.17.0 Vulnerable ·Agoric
Remediation
- Fix · CNA endo (endojs) Fixed in 0.18.7, 0.15.24, 0.14.5, 0.13.5
- Fix · GHSA-9c4h-3f7h-322r ses (npm) Fixed in 0.13.5 Advisory →
- Fix · GHSA-9c4h-3f7h-322r ses (npm) Fixed in 0.14.5 Advisory →
- Fix · GHSA-9c4h-3f7h-322r ses (npm) Fixed in 0.15.24 Advisory →
- Fix · GHSA-9c4h-3f7h-322r ses (npm) Fixed in 0.16.1 Advisory →
- Fix · GHSA-9c4h-3f7h-322r ses (npm) Fixed in 0.17.1 Advisory →
- Fix · GHSA-9c4h-3f7h-322r ses (npm) Fixed in 0.18.7 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-39532
- 2026-10-03 Alias added: GHSA-9c4h-3f7h-322r
References
More endojs vulnerabilities
- TI-2025-23829 ses's global contour bindings leak into Compartment lexical scope CVSS 4.0HIGH 8.7
Sources
- CVE-2023-39532 · CVE Program
- CVE-2023-39532 · NVD
- FIRST EPSS
- GHSA-9c4h-3f7h-322r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences