Absolute Path Traversal in Splunk Enterprise Using runshellscript.py
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
In Splunk Enterprise versions lower than 8.2.12, 9.0.6, and 9.1.1, an attacker can exploit an absolute path traversal to execute arbitrary code that is located on a separate disk.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Splunk | Splunk Enterprise | 8.2 to before 8.2.12; 9.0 to before 9.0.6; 9.1 to before 9.1.1 | 8.2.12, 9.0.6, 9.1.1 | Patch available | CNA |
| Splunk | Splunk Cloud | - to before 9.0.2305.200 | 9.0.2305.200 | Patch available | CNA |
- Splunk Enterprise VendorSplunk Affected 8.2 to before 8.2.12; 9.0 to before 9.0.6; 9.1 to before 9.1.1 Fixed in 8.2.12, 9.0.6, 9.1.1 Patch available CNA
- Splunk Cloud VendorSplunk Affected - to before 9.0.2305.200 Fixed in 9.0.2305.200 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:splunk:splunk:*:*:*:*:enterprise:*:*:* | 8.2.0 to before 8.2.12; 9.0.0 to before 9.0.6 | Vulnerable | Splunk |
| cpe:2.3:a:splunk:splunk:9.1.0:*:*:*:enterprise:*:*:* | 9.1.0 | Vulnerable | Splunk |
| cpe:2.3:a:splunk:splunk_cloud_platform:*:*:*:*:*:*:*:* | up to 9.0.2305.100 | Vulnerable | Splunk |
- cpe:2.3:a:splunk:splunk:*:*:*:*:enterprise:*:*:* Versions 8.2.0 to before 8.2.12; 9.0.0 to before 9.0.6 Vulnerable ·Splunk
- cpe:2.3:a:splunk:splunk:9.1.0:*:*:*:enterprise:*:*:* Versions 9.1.0 Vulnerable ·Splunk
- cpe:2.3:a:splunk:splunk_cloud_platform:*:*:*:*:*:*:*:* Versions up to 9.0.2305.100 Vulnerable ·Splunk
Remediation
- Fix · CNA Splunk Enterprise (Splunk) Fixed in 8.2.12, 9.0.6, 9.1.1
- Fix · CNA Splunk Cloud (Splunk) Fixed in 9.0.2305.200
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Splunk Enterprise 8.2.12, 9.0.6, 9.1.1
6 records Highest priority Priority MEDIUM 3 MEDIUM, 3 LOW
Other records, highest priority first
- TI-2023-21396 Command Injection in Splunk Enterprise Using External LookupsPriority MEDIUM 42
- TI-2023-21393 Remote Code Execution via Serialized Session PayloadPriority MEDIUM 40
- TI-2023-21394 Splunk Enterprise on Windows Privilege Escalation due to Insecure OPENSSLDIR Build Definition Reference in DLLPriority LOW 39
- Release ·
Splunk Cloud 9.0.2305.200
4 records Highest priority Priority MEDIUM 3 MEDIUM, 1 LOW
Other records, highest priority first
- TI-2023-21396 Command Injection in Splunk Enterprise Using External LookupsPriority MEDIUM 42
- TI-2023-21393 Remote Code Execution via Serialized Session PayloadPriority MEDIUM 40
- TI-2023-21390 Reflected Cross-site Scripting (XSS) on "/app/search/table" web endpointPriority LOW 39
Timeline
- 2026-10-02 Threatist record created from CVE-2023-40597
- 2026-10-03 Alias added: GHSA-prvp-v5vw-h6ph
References
More Splunk vulnerabilities
- TI-2026-16444 Unauthenticated Arbitrary File Creation and Truncation in a PostgreSQL Sidecar Service Endpoint in Splunk Enterprise KEVCVSS 3.1CRITICAL 9.8
- TI-2014-00154 The (1) TLS and (2) DTLS implementations in OpenSSL 1.0.1 before 1.0.1g do not properly… KEVCVSS 3.1HIGH 7.5
- TI-2023-24841 Remote code execution (RCE) in Splunk Enterprise through Insecure XML Parsing CVSS 3.1HIGH 8.8
- TI-2023-15979 ‘edit_user’ Capability Privilege Escalation CVSS 3.1HIGH 8.8
- TI-2024-30707 Remote Code Execution (RCE) due to insecure session storage configuration in Splunk Enterprise on Windows CVSS 3.1HIGH 8.8
- TI-2022-21345 Reflected Cross-Site Scripting via the radio template in Splunk Enterprise CVSS 3.1HIGH 8.8
Sources
- CVE-2023-40597 · CVE Program
- CVE-2023-40597 · NVD
- FIRST EPSS
- GHSA-prvp-v5vw-h6ph · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences