Trigger `beforeFind` not invoked in internal query pipeline in parse-server
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
Parse Server is an open source backend server. In affected versions the Parse Cloud trigger `beforeFind` is not invoked in certain conditions of `Parse.Query`. This can pose a vulnerability for deployments where the `beforeFind` trigger is used as a security layer to modify the incoming query. The vulnerability has been fixed by refactoring the internal query pipeline for a more concise code structure and implementing a patch to ensure the `beforeFind` trigger is invoked. This fix was introduced in commit `be4c7e23c6` and has been included in releases 6.2.2 and 5.5.5. Users are advised to upgrade. Users unable to upgrade should make use of parse server's security layers to manage access levels with Class-Level Permissions and Object-Level Access Control that should be used instead of custom security layers in Cloud Code triggers.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| parse-community | parse-server | 1.0.0 to before 5.5.5; 6.0.0 to before 6.2.2 | 5.5.5, 6.2.2 | Patch available | CNA |
| — | parse-server (npm) | 1.0.0 to before 5.5.5 | 5.5.5 | Patch available | GHSA-fcv6-fg5r-jm9q |
| — | parse-server (npm) | 6.0.0 to before 6.2.2 | 6.2.2 | Patch available | GHSA-fcv6-fg5r-jm9q |
- parse-server Vendorparse-community Affected 1.0.0 to before 5.5.5; 6.0.0 to before 6.2.2 Fixed in 5.5.5, 6.2.2 Patch available CNA
- parse-server (npm) Vendor— Affected 1.0.0 to before 5.5.5 Fixed in 5.5.5 Patch available GHSA-fcv6-fg5r-jm9q
- parse-server (npm) Vendor— Affected 6.0.0 to before 6.2.2 Fixed in 6.2.2 Patch available GHSA-fcv6-fg5r-jm9q
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:node.js:*:* | before 5.5.5; 6.0.0 to before 6.2.2 | Vulnerable | parse-community |
- cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:node.js:*:* Versions before 5.5.5; 6.0.0 to before 6.2.2 Vulnerable ·parse-community
Remediation
- Fix · CNA parse-server (parse-community) Fixed in 5.5.5, 6.2.2
- Fix · GHSA-fcv6-fg5r-jm9q parse-server (npm) Fixed in 5.5.5 Advisory →
- Fix · GHSA-fcv6-fg5r-jm9q parse-server (npm) Fixed in 6.2.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-41058
- 2026-10-03 Alias added: GHSA-fcv6-fg5r-jm9q
References
Patch 1
Advisory 2
More parse-community Parse-server vulnerabilities
- TI-2022-08574 Command Injection in Parse server CVSS 3.1CRITICAL 10.0
- TI-2024-18136 Parse Server literalizeRegexPart SQL Injection CVSS 3.1CRITICAL 10.0
- TI-2022-18768 Parse Server vulnerable to Remote Code Execution via prototype pollution in MongoDB BSON parser CVSS 3.1CRITICAL 9.8
- TI-2024-31550 Parse Server's custom object ID allows to acquire role privileges CVSS 3.1HIGH 8.1
- TI-2023-18316 Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution CVSS 3.1CRITICAL 9.8
- TI-2026-23790 Parse Server session token exfiltration via `redirectClassNameForKey` query parameter CVSS 4.0CRITICAL 9.9
Sources
- CVE-2023-41058 · CVE Program
- CVE-2023-41058 · NVD
- FIRST EPSS
- GHSA-fcv6-fg5r-jm9q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences