Read the docs
TI-2023-21917 Aliases CVE-2023-41317GHSA-w8vq-3hf9-xppx

Unnamed "Subscription" operation results in Denial-of-Service in apollographql/router

Priority MEDIUM 40CWE-755Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.

Summary

The Apollo Router is a configurable, high-performance graph router written in Rust to run a federated supergraph that uses Apollo Federation 2. Affected versions are subject to a Denial-of-Service (DoS) type vulnerability which causes the Router to panic and terminate when GraphQL Subscriptions are enabled. It can be triggered when **all of the following conditions are met**: 1. Running Apollo Router v1.28.0, v1.28.1 or v1.29.0 ("impacted versions"); **and** 2. The Supergraph schema provided to the Router (either via Apollo Uplink or explicitly via other configuration) **has a `subscription` type** with root-fields defined; **and** 3. The YAML configuration provided to the Router **has subscriptions enabled** (they are _disabled_ by default), either by setting `enabled: true` _or_ by setting a valid `mode` within the `subscriptions` object (as seen in [subscriptions' documentation](https://www.apollographql.com/docs/router/executing-operations/subscription-support/#router-setup)); **and** 4. An [anonymous](https://spec.graphql.org/draft/#sec-Anonymous-Operation-Definitions) (i.e., un-named) `subscription` operation (e.g., `subscription { ... }`) is received by the Router If **all four** of these criteria are met, the impacted versions will panic and terminate. There is no data-privacy risk or sensitive-information exposure aspect to this vulnerability. This is fixed in Apollo Router v1.29.1. Users are advised to upgrade. Updating to v1.29.1 should be a clear and simple upgrade path for those running impacted versions. However, if Subscriptions are **not** necessary for your Graph – but are enabled via configuration — then disabling subscriptions is another option to mitigate the risk.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00805 57th percentileScored 2026-11-07
Fix Fixed router (apollographql): 1.29.1apollo-router (crates.io): 1.29.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
apollographqlrouter1.28.0 to before 1.29.11.29.1Patch availableCNA
—apollo-router (crates.io)1.28.0 to before 1.29.11.29.1Patch availableGHSA-w8vq-3hf9-xppx
  • router Vendorapollographql Affected 1.28.0 to before 1.29.1 Fixed in 1.29.1 Patch available CNA
  • apollo-router (crates.io) Vendor— Affected 1.28.0 to before 1.29.1 Fixed in 1.29.1 Patch available GHSA-w8vq-3hf9-xppx

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apollographql:apollo_router:*:*:*:*:*:*:*:*1.28.0 to before 1.29.1Vulnerableapollographql
  • cpe:2.3:a:apollographql:apollo_router:*:*:*:*:*:*:*:* Versions 1.28.0 to before 1.29.1 Vulnerable ·apollographql

Remediation

  • Fix · CNA router (apollographql) Fixed in 1.29.1
  • Fix · GHSA-w8vq-3hf9-xppx apollo-router (crates.io) Fixed in 1.29.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-41317
  2. 2026-10-03 Alias added: GHSA-w8vq-3hf9-xppx

References

  • TI-2024-29063 Apollo Query Planner and Apollo Gateway may infinitely loop on sufficiently complex queries CVSS 3.1HIGH 7.5
  • TI-2024-29378 Apollo Router Coprocessors may cause Denial-of-Service when handling request bodies CVSS 3.1HIGH 7.5
  • TI-2024-18682 Apollo Router's Compressed Payloads do not respect HTTP Payload Limits CVSS 3.1HIGH 7.5
  • TI-2023-24573 Improper Check or Handling of Exceptional Conditions in apollo-router CVSS 3.1HIGH 7.5

Sources