Improper certificate validation in Dell Unity
Priority LOW 37CWE-295Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-295.
Summary
Dell Unity prior to 5.3 contains a 'man in the middle' vulnerability in the vmadapter component. If a customer has a certificate signed by a third-party public Certificate Authority, the vCenter CA could be spoofed by an attacker who can obtain a CA-signed certificate.
Why it matters now
EPSS 0.00295 22nd percentileScored 2026-11-07
Fix Fixed Unity (Dell): 5.3.0.0.5.120
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Dell | Unity | before 5.3.0.0.5.120 | 5.3.0.0.5.120 | Patch available | CNA |
- Unity VendorDell Affected before 5.3.0.0.5.120 Fixed in 5.3.0.0.5.120 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:dell:unity_operating_environment:*:*:*:*:*:*:*:* | before 5.3.0.0.5.120 | Vulnerable | Dell |
| cpe:2.3:a:dell:unity_xt_operating_environment:*:*:*:*:*:*:*:* | before 5.3.0.0.5.120 | Vulnerable | Dell |
| cpe:2.3:a:dell:unityvsa_operating_environment:*:*:*:*:*:*:*:* | before 5.3.0.0.5.120 | Vulnerable | Dell |
- cpe:2.3:a:dell:unity_operating_environment:*:*:*:*:*:*:*:* Versions before 5.3.0.0.5.120 Vulnerable ·Dell
- cpe:2.3:a:dell:unity_xt_operating_environment:*:*:*:*:*:*:*:* Versions before 5.3.0.0.5.120 Vulnerable ·Dell
- cpe:2.3:a:dell:unityvsa_operating_environment:*:*:*:*:*:*:*:* Versions before 5.3.0.0.5.120 Vulnerable ·Dell
Remediation
- Fix · CNA Unity (Dell) Fixed in 5.3.0.0.5.120
Timeline
- 2026-10-02 Threatist record created from CVE-2023-43082
- 2026-10-03 Alias added: GHSA-5p7c-7c2x-v2f8
References
More Dell Unity Operating Environment vulnerabilities
- TI-2025-24909 OS command injection in Dell Unity CVSS 3.1CRITICAL 9.8
- TI-2025-16296 OS command injection in Dell Unity CVSS 3.1CRITICAL 9.8
- TI-2024-33087 OS command injection in Dell Unity CVSS 3.1CRITICAL 9.8
- TI-2025-18126 OS command injection in Dell Unity CVSS 3.1CRITICAL 9.1
- TI-2022-11638 Missing brute-force protection in Dell Unity CVSS 3.1CRITICAL 9.8
- TI-2025-18125 OS command injection in Dell Unity CVSS 3.1HIGH 7.3
Sources
- CVE-2023-43082 · CVE Program
- CVE-2023-43082 · NVD
- FIRST EPSS
- GHSA-5p7c-7c2x-v2f8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences