Read the docs
TI-2023-23252 Aliases CVE-2023-43495GHSA-5j46-5hwq-gwh7

Cross-site scripting in Jenkins

Priority LOW 26CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Partial Red Hat: 3 without a fix

Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.

Summary

Jenkins 2.423 and earlier, LTS 2.414.1 and earlier does not escape the value of the 'caption' constructor parameter of 'ExpandableDetailsNote', resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to control this parameter.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0102 63rd percentileScored 2026-11-07
Fix Partial Jenkins (Jenkins Project): 2.424, 2.414.2org.jenkins-ci.main:jenkins-core (Maven): 2.414.2, 2.424Red Hat: 3 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
JenkinsJenkins—2.424, 2.414.2Patch availableCNA
—org.jenkins-ci.main:jenkins-core (Maven)2.50 to before 2.414.22.414.2Patch availableGHSA-5j46-5hwq-gwh7
—org.jenkins-ci.main:jenkins-core (Maven)2.415 to before 2.4242.424Patch availableGHSA-5j46-5hwq-gwh7
  • Jenkins VendorJenkins Affected — Fixed in 2.424, 2.414.2 Patch available CNA
  • org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 2.50 to before 2.414.2 Fixed in 2.414.2 Patch available GHSA-5j46-5hwq-gwh7
  • org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 2.415 to before 2.424 Fixed in 2.424 Patch available GHSA-5j46-5hwq-gwh7

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:*before 2.414.2VulnerableJenkins
cpe:2.3:a:jenkins:jenkins:*:*:*:*:-:*:*:*before 2.424VulnerableJenkins
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:* Versions before 2.414.2 Vulnerable ·Jenkins
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:-:*:*:* Versions before 2.424 Vulnerable ·Jenkins

Remediation

  • Fix · CNA Jenkins (Jenkins Project) Fixed in 2.424, 2.414.2
  • Fix · GHSA-5j46-5hwq-gwh7 org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.414.2 Advisory →
  • Fix · GHSA-5j46-5hwq-gwh7 org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.424 Advisory →

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Advisory ·

    Jenkins — Jenkins Security Advisory 2023-09-20

    5 records Highest priority Priority MEDIUM 1 MEDIUM, 4 LOW

    Other records, highest priority first

    • TI-2023-23253 Incorrect default permissions in JenkinsPriority MEDIUM 42
    • TI-2023-23255 In Jenkins 2.423 and earlier, LTS 2.414.1 and earlier, processing file uploads using…Priority LOW 39
    • TI-2023-23254 Unrestricted file upload in JenkinsPriority LOW 39

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
OpenShift Developer Tools and ServicesAffectedNo fix yet
Red Hat OpenShift Container Platform 3.11AffectedNo fix planned: Out of support scope
Red Hat OpenShift Container Platform 4AffectedNo fix yet

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-43495
  2. 2026-10-03 Alias added: GHSA-5j46-5hwq-gwh7

References

  • TI-2024-15885 Path traversal in Jenkins KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
  • TI-2017-14573 Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an… KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
  • TI-2015-04472 The Fingerprints pages in Jenkins before 1.638 and LTS before 1.625.2 might allow remote… KEVCVSS 3.1HIGH 7.5
  • TI-2016-07596 The remoting module in Jenkins before 2.32 and LTS before 2.19.3 allows remote attackers… CVSS 3.0CRITICAL 9.8
See all 293 →

Sources