Apache Guacamole: Integer overflow in handling of VNC image buffers
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-190 and the CVSS impact.
Summary
Apache Guacamole 1.5.3 and older do not consistently ensure that values received from a VNC server will not result in integer overflow. If a user connects to a malicious or compromised VNC server, specially-crafted data could result in memory corruption, possibly allowing arbitrary code to be executed with the privileges of the running guacd process. Users are recommended to upgrade to version 1.5.4, which fixes this issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2023-43826
- 2026-10-03 Alias added: GHSA-hhj4-xc5f-6f87
References
More Apache Guacamole vulnerabilities
- TI-2019-14123 SQLite 3.30.1 mishandles certain SELECT statements with a nonexistent VIEW, leading to an application crash. CVSS 3.1HIGH 7.5
- TI-2021-19751 Improper validation of SAML responses CVSS 3.1HIGH 8.8
- TI-2023-14404 Apache Guacamole: Use-after-free in handling of RDP audio input buffer CVSS 3.1HIGH 8.1
- TI-2017-02374 Race condition in Apache Guacamole CVSS 3.0HIGH 8.1
- TI-2018-01241 Prior to 1.0.0, Apache Guacamole used a cookie for client-side storage of the user's… CVSS 3.0HIGH 7.5
- TI-2024-23239 Apache Guacamole: Improper input validation of console codes CVSS 3.1HIGH 7.5
Sources
- CVE-2023-43826 · CVE Program
- CVE-2023-43826 · NVD
- FIRST EPSS
- GHSA-hhj4-xc5f-6f87 · GitHub Advisory Database · CC BY 4.0
- CVE-2023-43826 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences