Apache Guacamole: Improper input validation of console codes
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-129 and the CVSS impact.
Summary
The terminal emulator of Apache Guacamole 1.5.5 and older does not properly validate console codes received from servers via text-based protocols like SSH. If a malicious user has access to a text-based connection, a specially-crafted sequence of console codes could allow arbitrary code to be executed with the privileges of the running guacd process. Users are recommended to upgrade to version 1.6.0, which fixes this issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2024-35164
- 2026-10-03 Alias added: GHSA-8wh3-jcvc-qrmq
References
More Apache Guacamole vulnerabilities
- TI-2019-14123 SQLite 3.30.1 mishandles certain SELECT statements with a nonexistent VIEW, leading to an application crash. CVSS 3.1HIGH 7.5
- TI-2023-23512 Apache Guacamole: Integer overflow in handling of VNC image buffers CVSS 3.1HIGH 8.8
- TI-2021-19751 Improper validation of SAML responses CVSS 3.1HIGH 8.8
- TI-2023-14404 Apache Guacamole: Use-after-free in handling of RDP audio input buffer CVSS 3.1HIGH 8.1
- TI-2017-02374 Race condition in Apache Guacamole CVSS 3.0HIGH 8.1
- TI-2018-01241 Prior to 1.0.0, Apache Guacamole used a cookie for client-side storage of the user's… CVSS 3.0HIGH 7.5
Sources
- CVE-2024-35164 · CVE Program
- CVE-2024-35164 · NVD
- FIRST EPSS
- GHSA-8wh3-jcvc-qrmq · GitHub Advisory Database · CC BY 4.0
- CVE-2024-35164 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences