Apache ServiceComb Service-Center: attacker can query all environment variables of the service-center server
Priority MEDIUM 40CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
Exposure of Sensitive Information to an Unauthorized Actor in Apache ServiceComb Service-Center.This issue affects Apache ServiceComb Service-Center before 2.1.0 (include). Users are recommended to upgrade to version 2.2.0, which fixes the issue.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00814 57th percentileScored 2026-11-07
Fix Fixed github.com/apache/servicecomb-service-center (Go): 2.2.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache ServiceComb Service-Center | up to 2.1.0 | — | No fix listed | CNA |
| — | github.com/apache/servicecomb-service-center (Go) | before 2.2.0 | 2.2.0 | Patch available | GHSA-r8xp-52mq-rmm8 |
- Apache ServiceComb Service-Center VendorApache Affected up to 2.1.0 Fixed in — No fix listed CNA
- github.com/apache/servicecomb-service-center (Go) Vendor— Affected before 2.2.0 Fixed in 2.2.0 Patch available GHSA-r8xp-52mq-rmm8
Remediation
- Fix · GHSA-r8xp-52mq-rmm8 github.com/apache/servicecomb-service-center (Go) Fixed in 2.2.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-44312
- 2026-10-03 Alias added: GHSA-r8xp-52mq-rmm8
References
More Apache Servicecomb vulnerabilities
- TI-2021-04594 ServiceComb ServiceCenter Directory Traversal CVSS 3.1HIGH 7.5
- TI-2023-23832 Apache ServiceComb Service-Center: attacker can perform SSRF through the frontend API CVSS 3.1HIGH 7.6
Sources
- CVE-2023-44312 · CVE Program
- CVE-2023-44312 · NVD
- FIRST EPSS
- GHSA-r8xp-52mq-rmm8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences