Apache ServiceComb Service-Center: attacker can perform SSRF through the frontend API
Priority LOW 39CWE-918Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
Server-Side Request Forgery (SSRF) vulnerability in Apache ServiceComb Service-Center. Attackers can obtain sensitive server information through specially crafted requests.This issue affects Apache ServiceComb before 2.1.0(include). Users are recommended to upgrade to version 2.2.0, which fixes the issue.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0346 89th percentileScored 2026-11-07
Fix Fixed github.com/apache/servicecomb-service-center (Go): 2.2.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache ServiceComb Service-Center | up to 2.1.0 | — | No fix listed | CNA |
| — | github.com/apache/servicecomb-service-center (Go) | before 2.2.0 | 2.2.0 | Patch available | GHSA-9xc9-xq7w-vpcr |
- Apache ServiceComb Service-Center VendorApache Affected up to 2.1.0 Fixed in — No fix listed CNA
- github.com/apache/servicecomb-service-center (Go) Vendor— Affected before 2.2.0 Fixed in 2.2.0 Patch available GHSA-9xc9-xq7w-vpcr
Remediation
- Fix · GHSA-9xc9-xq7w-vpcr github.com/apache/servicecomb-service-center (Go) Fixed in 2.2.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-44313
- 2026-10-03 Alias added: GHSA-9xc9-xq7w-vpcr
References
More Apache Servicecomb vulnerabilities
- TI-2023-23831 Apache ServiceComb Service-Center: attacker can query all environment variables of the service-center server CVSS 3.1HIGH 7.5
- TI-2021-04594 ServiceComb ServiceCenter Directory Traversal CVSS 3.1HIGH 7.5
Sources
- CVE-2023-44313 · CVE Program
- CVE-2023-44313 · NVD
- FIRST EPSS
- GHSA-9xc9-xq7w-vpcr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences