Apache bRPC: The builtin service rpcz page has an XSS attack vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
Security vulnerability in Apache bRPC <=1.6.0 on all platforms allows attackers to inject XSS code to the builtin rpcz page. An attacker that can send http request to bRPC server with rpcz enabled can inject arbitrary XSS code to the builtin rpcz page. Solution (choose one of three): 1. upgrade to bRPC > 1.6.0, download link: https://dist.apache.org/repos/dist/release/brpc/1.6.1/ 2. If you are using an old version of bRPC and hard to upgrade, you can apply this patch: https://github.com/apache/brpc/pull/2411 3. disable rpcz feature
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2023-45757
- 2026-10-03 Alias added: GHSA-rjj3-fg8r-3rr5
References
More Apache Brpc vulnerabilities
- TI-2025-37397 Apache bRPC: Remote command injection vulnerability in heap builtin service CVSS 3.1CRITICAL 9.8
- TI-2023-14776 Apache bRPC: ServerOptions.pid_file may cause arbitrary code execution CVSS 3.1CRITICAL 9.8
- TI-2025-37239 Apache bRPC: Stack Exhaustion via Unbounded Recursion in JSON Parser CVSS 3.1HIGH 7.5
- TI-2025-34269 Apache bRPC: Redis Parser Remote Denial of Service CVSS 3.1HIGH 7.5
- TI-2024-15499 Apache bRPC: HTTP request smuggling vulnerability CVSS 3.1HIGH 7.5
Sources
- CVE-2023-45757 · CVE Program
- CVE-2023-45757 · NVD
- FIRST EPSS
- GHSA-rjj3-fg8r-3rr5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences