crypto-js PBKDF2 1,000 times weaker than specified in 1993 and 1.3M times weaker than current standard
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Partial Red Hat: 4 fixed, 2 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-327.
Summary
crypto-js is a JavaScript library of crypto standards. Prior to version 4.2.0, crypto-js PBKDF2 is 1,000 times weaker than originally specified in 1993, and at least 1,300,000 times weaker than current industry standard. This is because it both defaults to SHA1, a cryptographic hash algorithm considered insecure since at least 2005, and defaults to one single iteration, a 'strength' or 'difficulty' value specified at 1,000 when specified in 1993. PBKDF2 relies on iteration count as a countermeasure to preimage and collision attacks. If used to protect passwords, the impact is high. If used to generate signatures, the impact is high. Version 4.2.0 contains a patch for this issue. As a workaround, configure crypto-js to use SHA256 with at least 250,000 iterations.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| brix | crypto-js | before 4.2.0 | 4.2.0 | Patch available | CNA |
| — | crypto-js (npm) | before 4.2.0 | 4.2.0 | Patch available | GHSA-xwcq-pm8m-c4vf |
- crypto-js Vendorbrix Affected before 4.2.0 Fixed in 4.2.0 Patch available CNA
- crypto-js (npm) Vendor— Affected before 4.2.0 Fixed in 4.2.0 Patch available GHSA-xwcq-pm8m-c4vf
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:crypto-js_project:crypto-js:*:*:*:*:*:*:*:* | before 4.2.0 | Vulnerable | Crypto-js Project |
- cpe:2.3:a:crypto-js_project:crypto-js:*:*:*:*:*:*:*:* Versions before 4.2.0 Vulnerable ·Crypto-js Project
Remediation
- Fix · CNA crypto-js (brix) Fixed in 4.2.0
- Fix · GHSA-xwcq-pm8m-c4vf crypto-js (npm) Fixed in 4.2.0 Advisory →
Red Hat 6 advisories
- RHSA-2024:0806 Released 2024-02-13 · Red Hat rating Importantdotnet7.0 security update
- Red Hat CodeReady Linux Builder (v. 8) dotnet-sdk-7.0-source-built-artifacts-7.0.116-1.el8_9
- Red Hat Enterprise Linux AppStream (v. 8) aspnetcore-runtime-7.0-7.0.16-1.el8_9, aspnetcore-targeting-pack-7.0-7.0.16-1.el8_9, dotnet-apphost-pack-7.0-7.0.16-1.el8_9 +6
- RHSA-2024:0805 Released 2024-02-13 · Red Hat rating Importantdotnet7.0 security update
- Red Hat CodeReady Linux Builder (v. 9) dotnet-sdk-7.0-source-built-artifacts-7.0.116-1.el9_3
- Red Hat Enterprise Linux AppStream (v. 9) aspnetcore-runtime-7.0-7.0.16-1.el9_3, aspnetcore-targeting-pack-7.0-7.0.16-1.el9_3, dotnet-apphost-pack-7.0-7.0.16-1.el9_3 +6
- RHSA-2024:0157 Released 2024-01-10 · Red Hat rating Important.NET 7.0 security update
- Red Hat CodeReady Linux Builder (v. 8) dotnet-sdk-7.0-source-built-artifacts-7.0.115-1.el8_9
- Red Hat Enterprise Linux AppStream (v. 8) aspnetcore-runtime-7.0-7.0.15-1.el8_9, aspnetcore-targeting-pack-7.0-7.0.15-1.el8_9, dotnet-apphost-pack-7.0-7.0.15-1.el8_9 +6
Show 3 more Red Hat advisories
- RHSA-2024:0158 Released 2024-01-10 · Red Hat rating Important.NET 6.0 security update
- Red Hat CodeReady Linux Builder (v. 8) dotnet-sdk-6.0-source-built-artifacts-6.0.126-1.el8_9
- Red Hat Enterprise Linux AppStream (v. 8) aspnetcore-runtime-6.0-6.0.26-1.el8_9, aspnetcore-targeting-pack-6.0-6.0.26-1.el8_9, dotnet-apphost-pack-6.0-6.0.26-1.el8_9 +6
- RHSA-2024:0156 Released 2024-01-10 · Red Hat rating Important.NET 6.0 security update
- Red Hat CodeReady Linux Builder (v. 9) dotnet-sdk-6.0-source-built-artifacts-6.0.126-1.el9_3
- Red Hat Enterprise Linux AppStream (v. 9) aspnetcore-runtime-6.0-6.0.26-1.el9_3, aspnetcore-targeting-pack-6.0-6.0.26-1.el9_3, dotnet-apphost-pack-6.0-6.0.26-1.el9_3 +6
- RHSA-2024:0151 Released 2024-01-10 · Red Hat rating Important.NET 7.0 security update
- Red Hat CodeReady Linux Builder (v. 9) dotnet-sdk-7.0-source-built-artifacts-7.0.115-1.el9_3
- Red Hat Enterprise Linux AppStream (v. 9) aspnetcore-runtime-7.0-7.0.15-1.el9_3, aspnetcore-targeting-pack-7.0-7.0.15-1.el9_3, dotnet-apphost-pack-7.0-7.0.15-1.el9_3 +6
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| .NET 6.0 on Red Hat Enterprise Linux | Affected | No fix planned: Out of support scope |
| Red Hat build of Apicurio Registry 2 | Affected | No fix yet |
| Red Hat CodeReady Linux Builder (v. 8) | Fixed | RHSA-2024:0157, RHSA-2024:0158, RHSA-2024:0806 |
| Red Hat CodeReady Linux Builder (v. 9) | Fixed | RHSA-2024:0151, RHSA-2024:0156, RHSA-2024:0805 |
| Red Hat Enterprise Linux AppStream (v. 8) | Fixed | RHSA-2024:0157, RHSA-2024:0158, RHSA-2024:0806 |
| Red Hat Enterprise Linux AppStream (v. 9) | Fixed | RHSA-2024:0151, RHSA-2024:0156, RHSA-2024:0805 |
Timeline
- 2026-10-02 Threatist record created from CVE-2023-46233
- 2026-10-03 Alias added: GHSA-xwcq-pm8m-c4vf
- 2026-10-25 EPSS moved to the 50th–90th percentile
References
Advisory 2
More brix vulnerabilities
- TI-2026-50180 crypto-js: Insufficient Entropy in Cryptographic Secret Generation via Vulnerable CryptoJS Dependency Chain CVSS 3.1CRITICAL 9.0
Sources
- CVE-2023-46233 · CVE Program
- CVE-2023-46233 · NVD
- FIRST EPSS
- GHSA-xwcq-pm8m-c4vf · GitHub Advisory Database · CC BY 4.0
- CVE-2023-46233 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences