Symfony possible session fixation vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-384.
Summary
Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Starting in versions 5.4.21 and 6.2.7 and prior to versions 5.4.31 and 6.3.8, `SessionStrategyListener` does not migrate the session after every successful login. It does so only in case the logged in user changes by means of checking the user identifier. In some use cases, the user identifier doesn't change between the verification phase and the successful login, while the token itself changes from one type (partially-authenticated) to another (fully-authenticated). When this happens, the session id should be regenerated to prevent possible session fixations, which is not the case at the moment. As of versions 5.4.31 and 6.3.8, Symfony now checks the type of the token in addition to the user identifier before deciding whether the session id should be regenerated.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| symfony | symfony | 5.4.21 to before 5.4.31; 6.2.7 to before 6.3.8 | 5.4.31, 6.3.8 | Patch available | CNA |
| — | symfony/security-http (Packagist) | 5.4.21 to before 5.4.31 | 5.4.31 | Patch available | GHSA-m2wj-r6g3-fxfx |
| — | symfony/security-http (Packagist) | 6.2.7 to before 6.3.8 | 6.3.8 | Patch available | GHSA-m2wj-r6g3-fxfx |
| — | symfony/symfony (Packagist) | 5.4.21 to before 5.4.31 | 5.4.31 | Patch available | GHSA-m2wj-r6g3-fxfx |
| — | symfony/symfony (Packagist) | 6.2.7 to before 6.3.8 | 6.3.8 | Patch available | GHSA-m2wj-r6g3-fxfx |
- symfony Vendorsymfony Affected 5.4.21 to before 5.4.31; 6.2.7 to before 6.3.8 Fixed in 5.4.31, 6.3.8 Patch available CNA
- symfony/security-http (Packagist) Vendor— Affected 5.4.21 to before 5.4.31 Fixed in 5.4.31 Patch available GHSA-m2wj-r6g3-fxfx
- symfony/security-http (Packagist) Vendor— Affected 6.2.7 to before 6.3.8 Fixed in 6.3.8 Patch available GHSA-m2wj-r6g3-fxfx
- symfony/symfony (Packagist) Vendor— Affected 5.4.21 to before 5.4.31 Fixed in 5.4.31 Patch available GHSA-m2wj-r6g3-fxfx
- symfony/symfony (Packagist) Vendor— Affected 6.2.7 to before 6.3.8 Fixed in 6.3.8 Patch available GHSA-m2wj-r6g3-fxfx
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sensiolabs:symfony:*:*:*:*:*:*:*:* | 5.4.21 to before 5.4.31; 6.2.7 to before 6.3.8 | Vulnerable | sensiolabs |
- cpe:2.3:a:sensiolabs:symfony:*:*:*:*:*:*:*:* Versions 5.4.21 to before 5.4.31; 6.2.7 to before 6.3.8 Vulnerable ·sensiolabs
Remediation
- Fix · CNA symfony (symfony) Fixed in 5.4.31, 6.3.8
- Fix · GHSA-m2wj-r6g3-fxfx symfony/security-http (Packagist) Fixed in 5.4.31 Advisory →
- Fix · GHSA-m2wj-r6g3-fxfx symfony/security-http (Packagist) Fixed in 6.3.8 Advisory →
- Fix · GHSA-m2wj-r6g3-fxfx symfony/symfony (Packagist) Fixed in 5.4.31 Advisory →
- Fix · GHSA-m2wj-r6g3-fxfx symfony/symfony (Packagist) Fixed in 6.3.8 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2023-46733
- 2026-10-03 Alias added: GHSA-m2wj-r6g3-fxfx
References
Patch 3
More symfony vulnerabilities
- TI-2024-33775 Ability to change environment from query in symfony/runtime CVSS 3.1HIGH 7.3
- TI-2026-34283 Twig: The `spaceless` filter implicitly marks its output as safe CVSS 4.0MEDIUM 5.1
- TI-2022-07667 Code injection in Twig CVSS 3.1CRITICAL 9.8
- TI-2018-10028 Twig before 2.4.4 allows Server-Side Template Injection (SSTI) via the search search_key… CVSS 3.0CRITICAL 9.8
- TI-2026-35851 Incorrect authorization in symfony CVSS 4.0HIGH 8.7
- TI-2026-35264 Improper input validation in symfony CVSS 4.0HIGH 8.3
Sources
- CVE-2023-46733 · CVE Program
- CVE-2023-46733 · NVD
- FIRST EPSS
- GHSA-m2wj-r6g3-fxfx · GitHub Advisory Database · CC BY 4.0
- CVE-2023-46733 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences