Symfony potential Cross-site Scripting in WebhookController
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Starting in version 6.0.0 and prior to version 6.3.8, the error message in `WebhookController` returns unescaped user-submitted input. As of version 6.3.8, `WebhookController` now doesn't return any user-submitted input in its response.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| symfony | symfony | 6.3.0 to before 6.3.8 | 6.3.8 | Patch available | CNA |
| — | symfony/webhook (Packagist) | 6.3.0 to before 6.3.8 | 6.3.8 | Patch available | GHSA-72x2-5c85-6wmr |
| — | symfony/symfony (Packagist) | 6.3.0 to before 6.3.8 | 6.3.8 | Patch available | GHSA-72x2-5c85-6wmr |
- symfony Vendorsymfony Affected 6.3.0 to before 6.3.8 Fixed in 6.3.8 Patch available CNA
- symfony/webhook (Packagist) Vendor— Affected 6.3.0 to before 6.3.8 Fixed in 6.3.8 Patch available GHSA-72x2-5c85-6wmr
- symfony/symfony (Packagist) Vendor— Affected 6.3.0 to before 6.3.8 Fixed in 6.3.8 Patch available GHSA-72x2-5c85-6wmr
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sensiolabs:symfony:*:*:*:*:*:*:*:* | 6.0.0 to before 6.3.8 | Vulnerable | sensiolabs |
- cpe:2.3:a:sensiolabs:symfony:*:*:*:*:*:*:*:* Versions 6.0.0 to before 6.3.8 Vulnerable ·sensiolabs
Remediation
- Fix · CNA symfony (symfony) Fixed in 6.3.8
- Fix · GHSA-72x2-5c85-6wmr symfony/webhook (Packagist) Fixed in 6.3.8 Advisory →
- Fix · GHSA-72x2-5c85-6wmr symfony/symfony (Packagist) Fixed in 6.3.8 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2023-46735
- 2026-10-03 Alias added: GHSA-72x2-5c85-6wmr
References
Patch 2
More symfony vulnerabilities
- TI-2024-33775 Ability to change environment from query in symfony/runtime CVSS 3.1HIGH 7.3
- TI-2026-34283 Twig: The `spaceless` filter implicitly marks its output as safe CVSS 4.0MEDIUM 5.1
- TI-2022-07667 Code injection in Twig CVSS 3.1CRITICAL 9.8
- TI-2018-10028 Twig before 2.4.4 allows Server-Side Template Injection (SSTI) via the search search_key… CVSS 3.0CRITICAL 9.8
- TI-2026-35851 Incorrect authorization in symfony CVSS 4.0HIGH 8.7
- TI-2026-35264 Improper input validation in symfony CVSS 4.0HIGH 8.3
Sources
- CVE-2023-46735 · CVE Program
- CVE-2023-46735 · NVD
- FIRST EPSS
- GHSA-72x2-5c85-6wmr · GitHub Advisory Database · CC BY 4.0
- CVE-2023-46735 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences