Read the docs
TI-2023-25892 Aliases CVE-2023-47782GHSA-jcw3-r84f-h8jq

WordPress Thrive Theme Builder theme < 3.24.0 - Authenticated Privilege Escalation vulnerability

Priority MEDIUM 41CWE-269Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Privilege escalation
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-269.

Summary

Improper Privilege Management vulnerability in Thrive Themes Thrive Theme Builder allows Privilege Escalation.This issue affects Thrive Theme Builder: from n/a before 3.24.0.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00526 44th percentileScored 2026-11-07
Fix Fixed Thrive Theme Builder (Thrive Themes): 3.24.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
Thrive ThemesThrive Theme Builderbefore 3.24.03.24.0Patch availableCNA
  • Thrive Theme Builder VendorThrive Themes Affected before 3.24.0 Fixed in 3.24.0 Patch available CNA

CPE names CISA-ADP · 1

CPEVersionsRoleVendor
cpe:2.3:a:thrivethemes:thrive_themes_builder:*:*:*:*:*:*:*:*——Thrive Themes
  • cpe:2.3:a:thrivethemes:thrive_themes_builder:*:*:*:*:*:*:*:* Versions — — ·Thrive Themes

Remediation

  • Fix · CNA Thrive Theme Builder (Thrive Themes) Fixed in 3.24.0

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-47782
  2. 2026-10-03 Alias added: GHSA-jcw3-r84f-h8jq

References

  • TI-2026-36331 WordPress Thrive Apprentice plugin < 10.8.10.2 - PHP Object Injection vulnerability CVSS 3.1CRITICAL 9.8
  • TI-2021-06512 All Thrive Themes Legacy Themes < 2.0.0 - Unauthenticated Arbitrary File Upload and Option Deletion CVSS 3.1CRITICAL 9.1
  • TI-2023-28183 WordPress Thrive Automator Plugin <= 1.17 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
  • TI-2023-25891 WordPress Thrive Theme Builder Theme < 3.24.2 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
  • TI-2023-25893 WordPress Thrive Theme Builder theme < 3.24.0 - Multiple Authenticated Broken Access Control vulnerability CVSS 3.1HIGH 8.3
  • TI-2021-06511 All Thrive Themes and Plugins - Unauthenticated Option Update CVSS 3.1MEDIUM 5.3

Sources