Denial of Service via Board Import Zip Bomb
Priority LOW 34CWE-400Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-400.
Summary
Mattermost fails to limit the amount of data extracted from compressed archives during board import in Mattermost Boards allowing an attacker to consume excessive resources, possibly leading to Denial of Service, by importing a board using a specially crafted zip (zip bomb).
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00723 54th percentileScored 2026-11-07
Fix Fixed Mattermost (Mattermost): 9.1.1, 9.0.2, 7.8.13 +1github.com/mattermost/mattermost/server/v8 (Go): 9.1.1, 9.0.2, 8.1.4+1 more product
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Mattermost | Mattermost | up to 7.8.12; up to 8.1.3; up to 9.0.1; up to 9.1.0 | 9.1.1, 9.0.2, 7.8.13, 8.1.4 | Patch available | CNA |
| — | github.com/mattermost/mattermost/server/v8 (Go) | 9.1.0 to before 9.1.1 | 9.1.1 | Patch available | GHSA-j4c3-3h73-74m9 |
| — | github.com/mattermost/mattermost/server/v8 (Go) | 9.0.0 to before 9.0.2 | 9.0.2 | Patch available | GHSA-j4c3-3h73-74m9 |
| — | github.com/mattermost/mattermost/server/v8 (Go) | before 8.1.4 | 8.1.4 | Patch available | GHSA-j4c3-3h73-74m9 |
| — | github.com/mattermost/mattermost-server/v6 (Go) | before 7.8.13 | 7.8.13 | Patch available | GHSA-j4c3-3h73-74m9 |
- Mattermost VendorMattermost Affected up to 7.8.12; up to 8.1.3; up to 9.0.1; up to 9.1.0 Fixed in 9.1.1, 9.0.2, 7.8.13, 8.1.4 Patch available CNA
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 9.1.0 to before 9.1.1 Fixed in 9.1.1 Patch available GHSA-j4c3-3h73-74m9
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 9.0.0 to before 9.0.2 Fixed in 9.0.2 Patch available GHSA-j4c3-3h73-74m9
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected before 8.1.4 Fixed in 8.1.4 Patch available GHSA-j4c3-3h73-74m9
- github.com/mattermost/mattermost-server/v6 (Go) Vendor— Affected before 7.8.13 Fixed in 7.8.13 Patch available GHSA-j4c3-3h73-74m9
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mattermost:mattermost:*:*:*:*:*:*:*:* | up to 7.8.12; 8.0.0 – 8.1.3; 9.0.0 – 9.0.1 | Vulnerable | Mattermost |
| cpe:2.3:a:mattermost:mattermost:9.1.0:*:*:*:*:*:*:* | 9.1.0 | Vulnerable | Mattermost |
- cpe:2.3:a:mattermost:mattermost:*:*:*:*:*:*:*:* Versions up to 7.8.12; 8.0.0 – 8.1.3; 9.0.0 – 9.0.1 Vulnerable ·Mattermost
- cpe:2.3:a:mattermost:mattermost:9.1.0:*:*:*:*:*:*:* Versions 9.1.0 Vulnerable ·Mattermost
Remediation
- Fix · CNA Mattermost (Mattermost) Fixed in 9.1.1, 9.0.2, 7.8.13, 8.1.4
- Fix · GHSA-j4c3-3h73-74m9 github.com/mattermost/mattermost/server/v8 (Go) Fixed in 9.1.1 Advisory →
- Fix · GHSA-j4c3-3h73-74m9 github.com/mattermost/mattermost/server/v8 (Go) Fixed in 9.0.2 Advisory →
- Fix · GHSA-j4c3-3h73-74m9 github.com/mattermost/mattermost/server/v8 (Go) Fixed in 8.1.4 Advisory →
- Fix · GHSA-j4c3-3h73-74m9 github.com/mattermost/mattermost-server/v6 (Go) Fixed in 7.8.13 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-48268
- 2026-10-03 Alias added: GHSA-j4c3-3h73-74m9
References
More Mattermost vulnerabilities
- TI-2024-26695 Malicious remote can invite itself to an arbitrary local channel CVSS 3.1CRITICAL 9.6
- TI-2023-02056 Oauth authorization codes do not expire when deauthorizing an oauth2 app CVSS 3.1CRITICAL 9.1
- TI-2019-15069 An issue was discovered in Mattermost Mobile Apps before 1.26.0. CVSS 3.1CRITICAL 9.1
- TI-2024-26233 Malicious remote can add users to arbitrary teams and channels CVSS 3.1HIGH 8.7
- TI-2024-26746 Permanently local data deletion by malicious remote CVSS 3.1HIGH 8.7
- TI-2023-06508 Injection in Mattermost CVSS 3.1HIGH 8.8
Sources
- CVE-2023-48268 · CVE Program
- CVE-2023-48268 · NVD
- FIRST EPSS
- GHSA-j4c3-3h73-74m9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences