quic-go's path validation mechanism can cause denial of service
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 2 fixed, 4 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-400.
Summary
quic-go is an implementation of the QUIC protocol (RFC 9000, RFC 9001, RFC 9002) in Go. An attacker can cause its peer to run out of memory sending a large number of PATH_CHALLENGE frames. The receiver is supposed to respond to each PATH_CHALLENGE frame with a PATH_RESPONSE frame. The attacker can prevent the receiver from sending out (the vast majority of) these PATH_RESPONSE frames by collapsing the peers congestion window (by selectively acknowledging received packets) and by manipulating the peer's RTT estimate. This vulnerability has been patched in versions 0.37.7, 0.38.2 and 0.39.4.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| quic-go | quic-go | = 0.40.0; 0.39.0 to before 0.39.4; 0.38.0 to before 0.38.2; before 0.37.7 | 0.39.4, 0.38.2, 0.37.7 | Patch available | CNA |
| — | github.com/quic-go/quic-go (Go) | 0.40.0 to before 0.40.1 | 0.40.1 | Patch available | GHSA-ppxx-5m9h-6vxf |
| — | github.com/quic-go/quic-go (Go) | 0.39.0 to before 0.39.4 | 0.39.4 | Patch available | GHSA-ppxx-5m9h-6vxf |
| — | github.com/quic-go/quic-go (Go) | 0.38.0 to before 0.38.2 | 0.38.2 | Patch available | GHSA-ppxx-5m9h-6vxf |
| — | github.com/quic-go/quic-go (Go) | before 0.37.7 | 0.37.7 | Patch available | GHSA-ppxx-5m9h-6vxf |
- quic-go Vendorquic-go Affected = 0.40.0; 0.39.0 to before 0.39.4; 0.38.0 to before 0.38.2; before 0.37.7 Fixed in 0.39.4, 0.38.2, 0.37.7 Patch available CNA
- github.com/quic-go/quic-go (Go) Vendor— Affected 0.40.0 to before 0.40.1 Fixed in 0.40.1 Patch available GHSA-ppxx-5m9h-6vxf
- github.com/quic-go/quic-go (Go) Vendor— Affected 0.39.0 to before 0.39.4 Fixed in 0.39.4 Patch available GHSA-ppxx-5m9h-6vxf
- github.com/quic-go/quic-go (Go) Vendor— Affected 0.38.0 to before 0.38.2 Fixed in 0.38.2 Patch available GHSA-ppxx-5m9h-6vxf
- github.com/quic-go/quic-go (Go) Vendor— Affected before 0.37.7 Fixed in 0.37.7 Patch available GHSA-ppxx-5m9h-6vxf
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:quic-go_project:quic-go:*:*:*:*:*:*:*:* | before 0.37.7; 0.38.0 to before 0.38.2; 0.39.0 to before 0.39.4 | Vulnerable | Quic-go Project |
| cpe:2.3:a:quic-go_project:quic-go:0.40.0:*:*:*:*:*:*:* | 0.40.0 | Vulnerable | Quic-go Project |
- cpe:2.3:a:quic-go_project:quic-go:*:*:*:*:*:*:*:* Versions before 0.37.7; 0.38.0 to before 0.38.2; 0.39.0 to before 0.39.4 Vulnerable ·Quic-go Project
- cpe:2.3:a:quic-go_project:quic-go:0.40.0:*:*:*:*:*:*:* Versions 0.40.0 Vulnerable ·Quic-go Project
Remediation
- Fix · CNA quic-go (quic-go) Fixed in 0.39.4, 0.38.2, 0.37.7
- Fix · GHSA-ppxx-5m9h-6vxf github.com/quic-go/quic-go (Go) Fixed in 0.40.1 Advisory →
- Fix · GHSA-ppxx-5m9h-6vxf github.com/quic-go/quic-go (Go) Fixed in 0.39.4 Advisory →
- Fix · GHSA-ppxx-5m9h-6vxf github.com/quic-go/quic-go (Go) Fixed in 0.38.2 Advisory →
- Fix · GHSA-ppxx-5m9h-6vxf github.com/quic-go/quic-go (Go) Fixed in 0.37.7 Advisory →
Red Hat 1 advisory
- RHSA-2024:0855 Released 2024-02-19 · Red Hat rating ModerateRed Hat Ansible Automation Platform 2.4 Product Security and Bug Fix Update
- Red Hat Ansible Automation Platform 2.4 for RHEL 8 receptor-1.4.4-1.el8ap
- Red Hat Ansible Automation Platform 2.4 for RHEL 9 receptor-1.4.4-1.el9ap
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| OpenShift Service Mesh 2 | Affected | No fix planned: Will not fix |
| Red Hat Advanced Cluster Management for Kubernetes 2 | Affected | No fix yet |
| Red Hat OpenShift Container Platform 4 | Affected | No fix yet |
| Red Hat OpenShift Dev Spaces | Affected | No fix yet: Fix deferred |
| Red Hat Ansible Automation Platform 2.4 for RHEL 8 | Fixed | RHSA-2024:0855 |
| Red Hat Ansible Automation Platform 2.4 for RHEL 9 | Fixed | RHSA-2024:0855 |
Not affected: 3 products
- OpenShift API for Data Protection
- Red Hat Ansible Automation Platform 2.4 for RHEL 8
- Red Hat Ansible Automation Platform 2.4 for RHEL 9
Timeline
- 2026-10-02 Threatist record created from CVE-2023-49295
- 2026-10-03 Alias added: GHSA-ppxx-5m9h-6vxf
References
Patch 8
- https://github.com/quic-go/quic-go/commit/17fc98c2d81dbe685c19702dc694a9d606ac56dc
- https://github.com/quic-go/quic-go/commit/21609ddfeff93668c7625a85eb09f1541fdad965
- https://github.com/quic-go/quic-go/commit/3a9c18bcd27a01c551ac9bf8bd2b4bded77c189a
- https://github.com/quic-go/quic-go/commit/554d543b50b917369fb1394cc5396d928166cf49
- https://github.com/quic-go/quic-go/commit/6cc3d58935426191296171a6c0d1ee965e10534e
- https://github.com/quic-go/quic-go/commit/9aaefe19fc3dc8c8917cc87e6128bb56d9e9e6cc
- https://github.com/quic-go/quic-go/commit/a0ffa757499913f7be69aa78f573a6aee3430ae4
- https://github.com/quic-go/quic-go/commit/d7aa627ebde91cf799ada2a07443faa9b1e5abb8
Advisory 2
Other 6
- https://lists.fedoraproject.org/archives/list/[email protected]/message/G5RSHDTVMYAIGYVVFGKTMFHAZJMA3EVV/
- https://lists.fedoraproject.org/archives/list/[email protected]/message/ZE7IOKXX5AATU2WR3V76X5Y3A44QAATG/
- https://github.com/quic-go/quic-go
- https://lists.fedoraproject.org/archives/list/[email protected]/message/G5RSHDTVMYAIGYVVFGKTMFHAZJMA3EVV
- https://lists.fedoraproject.org/archives/list/[email protected]/message/ZE7IOKXX5AATU2WR3V76X5Y3A44QAATG
- https://seemann.io/posts/2023-12-18-exploiting-quics-path-validation
More quic-go vulnerabilities
- TI-2024-14782 QUIC's Connection ID Mechanism vulnerable to Memory Exhaustion Attack CVSS 3.1HIGH 7.5
- TI-2023-24866 quic-go vulnerable to pointer dereference that can lead to panic CVSS 3.1HIGH 7.5
- TI-2026-29554 quic-go: HTTP/3 QPACK Trailer Expansion Memory Exhaustion CVSS 3.1HIGH 7.5
- TI-2026-17320 webtransport-go CloseWithError can block indefinitely CVSS 3.1HIGH 7.5
- TI-2026-17319 webtransport-go affected by Memory Exhaustion Attack due to Missing Length Check in WT_CLOSE_SESSION Capsule CVSS 3.1HIGH 7.5
- TI-2025-37061 quic-go has Client Crash Due to Premature HANDSHAKE_DONE Frame CVSS 3.1HIGH 7.5
Sources
- CVE-2023-49295 · CVE Program
- CVE-2023-49295 · NVD
- FIRST EPSS
- GHSA-ppxx-5m9h-6vxf · GitHub Advisory Database · CC BY 4.0
- CVE-2023-49295 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences