Sentry's Astro SDK vulnerable to ReDoS
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-400.
Summary
Sentry-Javascript is official Sentry SDKs for JavaScript. A ReDoS (Regular expression Denial of Service) vulnerability has been identified in Sentry's Astro SDK 7.78.0-7.86.0. Under certain conditions, this vulnerability allows an attacker to cause excessive computation times on the server, leading to denial of service (DoS). This vulnerability has been patched in sentry/astro version 7.87.0.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| getsentry | sentry-javascript | 7.78.0 to before 7.87.0 | 7.87.0 | Patch available | CNA |
| — | @sentry/astro (npm) | 7.78.0 to before 7.87.0 | 7.87.0 | Patch available | GHSA-x3v3-8xg8-8v72 |
- sentry-javascript Vendorgetsentry Affected 7.78.0 to before 7.87.0 Fixed in 7.87.0 Patch available CNA
- @sentry/astro (npm) Vendor— Affected 7.78.0 to before 7.87.0 Fixed in 7.87.0 Patch available GHSA-x3v3-8xg8-8v72
Remediation
- Fix · CNA sentry-javascript (getsentry) Fixed in 7.87.0
- Fix · GHSA-x3v3-8xg8-8v72 @sentry/astro (npm) Fixed in 7.87.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-50249
- 2026-10-03 Alias added: GHSA-x3v3-8xg8-8v72
References
Patch 2
Advisory 2
More getsentry vulnerabilities
- TI-2026-21018 Sentry allows unauthorized access to event data across organizational boundaries CVSS 4.0MEDIUM 5.7
- TI-2026-30656 Sentry: Improper authentication on SAML SSO process allows user identity linking CVSS 3.1CRITICAL 9.8
- TI-2026-78982 Sentry-Javascript: Middleware Bypass when using Tunnel route CVSS 4.0CRITICAL 9.1
- TI-2025-16094 Improper authentication on SAML SSO process allows user impersonation in sentry CVSS 3.1CRITICAL 9.1
- TI-2023-25212 Sentry Next.js vulnerable to SSRF via Next.js SDK tunnel endpoint CVSS 3.1CRITICAL 9.3
- TI-2026-21634 Sentry: Improper Authentication on SAML SSO process allows user identity linking CVSS 3.1CRITICAL 9.1
Sources
- CVE-2023-50249 · CVE Program
- CVE-2023-50249 · NVD
- FIRST EPSS
- GHSA-x3v3-8xg8-8v72 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences