layui up to v2.74 was discovered to contain a cross-site scripting (XSS) vulnerability via the data-content parameter.
Priority LOW 24CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
layui up to v2.74 was discovered to contain a cross-site scripting (XSS) vulnerability via the data-content parameter.
Why it matters now
EPSS 0.00283 20th percentileScored 2026-11-07
Fix Fixed layui (npm): 2.7.5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | layui (npm) | before 2.7.5 | 2.7.5 | Patch available | GHSA-rcvr-8whx-3m5p |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- layui (npm) Vendor— Affected before 2.7.5 Fixed in 2.7.5 Patch available GHSA-rcvr-8whx-3m5p
Remediation
- Fix · GHSA-rcvr-8whx-3m5p layui (npm) Fixed in 2.7.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-50550
- 2026-10-03 Alias added: GHSA-rcvr-8whx-3m5p
References
More Layui vulnerabilities
- TI-2024-31457 DOM Clobbering gadgets found in layui that lead to Cross-site Scripting CVSS 3.1MEDIUM 6.4
- TI-2023-03448 layui HTML Attribute cross site scripting CVSS 3.1MEDIUM 6.1
Sources
- CVE-2023-50550 · CVE Program
- CVE-2023-50550 · NVD
- FIRST EPSS
- GHSA-rcvr-8whx-3m5p · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences