Read the docs
TI-2024-31457 Aliases CVE-2024-47075GHSA-j827-6rgf-9629

DOM Clobbering gadgets found in layui that lead to Cross-site Scripting

Priority LOW 28CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
High
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

LayUI is a native minimalist modular Web UI component library. Versions prior to 2.9.17 have a DOM Clobbering vulnerability that can lead to Cross-site Scripting (XSS) on web pages where attacker-controlled HTML elements (e.g., `img` tags with unsanitized `name` attributes) are present. Version 2.9.17 fixes this issue.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00339 27th percentileScored 2026-11-07
Fix Fixed layui (layui): 2.9.17layui (npm): 2.9.17

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
layuilayuibefore 2.9.172.9.17Patch availableCNA
—layui (npm)before 2.9.172.9.17Patch availableGHSA-j827-6rgf-9629
  • layui Vendorlayui Affected before 2.9.17 Fixed in 2.9.17 Patch available CNA
  • layui (npm) Vendor— Affected before 2.9.17 Fixed in 2.9.17 Patch available GHSA-j827-6rgf-9629

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:layui:layui:*:*:*:*:*:*:*:*before 2.9.17Vulnerablelayui
  • cpe:2.3:a:layui:layui:*:*:*:*:*:*:*:* Versions before 2.9.17 Vulnerable ·layui

Remediation

  • Fix · CNA layui (layui) Fixed in 2.9.17
  • Fix · GHSA-j827-6rgf-9629 layui (npm) Fixed in 2.9.17 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-47075
  2. 2026-10-03 Alias added: GHSA-j827-6rgf-9629

References

  • TI-2023-03448 layui HTML Attribute cross site scripting CVSS 3.1MEDIUM 6.1
  • TI-2023-27620 layui up to v2.74 was discovered to contain a cross-site scripting (XSS) vulnerability via the data-content parameter. CVSS 3.1MEDIUM 5.4

Sources