Read the docs
TI-2023-27654 Aliases CVE-2023-50708GHSA-w8vh-p74j-x9xp

Observable discrepancy in Yiiframework yii2-authclient

Priority MEDIUM 43CWE-203Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-203.

Summary

yii2-authclient is an extension that adds OpenID, OAuth, OAuth2 and OpenId Connect consumers for the Yii framework 2.0. In yii2-authclient prior to version 2.2.15, the Oauth1/2 `state` and OpenID Connect `nonce` is vulnerable for a `timing attack` since it is compared via regular string comparison (instead of `Yii::$app->getSecurity()->compareString()`). Version 2.2.15 contains a patch for the issue. No known workarounds are available.

Why it matters now

EPSS 0.00716 54th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed yii2-authclient (yiisoft): 2.2.15yiisoft/yii2-authclient (Packagist): 2.2.15

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
Yiiframeworkyii2-authclientbefore 2.2.152.2.15Patch availableCNA
—yiisoft/yii2-authclient (Packagist)before 2.2.152.2.15Patch availableGHSA-w8vh-p74j-x9xp
  • yii2-authclient VendorYiiframework Affected before 2.2.15 Fixed in 2.2.15 Patch available CNA
  • yiisoft/yii2-authclient (Packagist) Vendor— Affected before 2.2.15 Fixed in 2.2.15 Patch available GHSA-w8vh-p74j-x9xp

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:yiiframework:yii2-authclient:*:*:*:*:*:*:*:*before 2.2.15VulnerableYiiframework
  • cpe:2.3:a:yiiframework:yii2-authclient:*:*:*:*:*:*:*:* Versions before 2.2.15 Vulnerable ·Yiiframework

Remediation

  • Fix · CNA yii2-authclient (yiisoft) Fixed in 2.2.15
  • Fix · GHSA-w8vh-p74j-x9xp yiisoft/yii2-authclient (Packagist) Fixed in 2.2.15 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-50708
  2. 2026-10-03 Alias added: GHSA-w8vh-p74j-x9xp

References

  • TI-2023-27660 The Oauth2 PKCE implementation is vulnerable CVSS 3.1HIGH 8.8

Sources