The Oauth2 PKCE implementation is vulnerable
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-347.
Summary
yii2-authclient is an extension that adds OpenID, OAuth, OAuth2 and OpenId Connect consumers for the Yii framework 2.0. In yii2-authclient prior to version 2.2.15, the Oauth2 PKCE implementation is vulnerable in 2 ways. First, the `authCodeVerifier` should be removed after usage (similar to `authState`). Second, there is a risk for a `downgrade attack` if PKCE is being relied on for CSRF protection. Version 2.2.15 contains a patch for the issue. No known workarounds are available.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Yiiframework | yii2-authclient | before 2.2.15 | 2.2.15 | Patch available | CNA |
| — | yiisoft/yii2-authclient (Packagist) | before 2.2.15 | 2.2.15 | Patch available | GHSA-rw54-6826-c8j5 |
- yii2-authclient VendorYiiframework Affected before 2.2.15 Fixed in 2.2.15 Patch available CNA
- yiisoft/yii2-authclient (Packagist) Vendor— Affected before 2.2.15 Fixed in 2.2.15 Patch available GHSA-rw54-6826-c8j5
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:yiiframework:yii2-authclient:*:*:*:*:*:*:*:* | before 2.2.15 | Vulnerable | Yiiframework |
- cpe:2.3:a:yiiframework:yii2-authclient:*:*:*:*:*:*:*:* Versions before 2.2.15 Vulnerable ·Yiiframework
Remediation
- Fix · CNA yii2-authclient (yiisoft) Fixed in 2.2.15
- Fix · GHSA-rw54-6826-c8j5 yiisoft/yii2-authclient (Packagist) Fixed in 2.2.15 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-50714
- 2026-10-03 Alias added: GHSA-rw54-6826-c8j5
References
Other 4
- https://github.com/yiisoft/yii2-authclient/blob/0d1c3880f4d79e20aa1d77c012650b54e69695ff/src/OAuth1.php#L158
- https://github.com/yiisoft/yii2-authclient/blob/0d1c3880f4d79e20aa1d77c012650b54e69695ff/src/OAuth2.php#L121
- https://github.com/yiisoft/yii2-authclient/blob/0d1c3880f4d79e20aa1d77c012650b54e69695ff/src/OpenIdConnect.php#L420
- https://github.com/yiisoft/yii2-authclient
More Yiiframework Yii2-authclient vulnerabilities
- TI-2023-27654 Observable discrepancy in Yiiframework yii2-authclient CVSS 3.1CRITICAL 9.8
Sources
- CVE-2023-50714 · CVE Program
- CVE-2023-50714 · NVD
- FIRST EPSS
- GHSA-rw54-6826-c8j5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences