PocketMine-MP before 5.3.1 Denial of Service via LoginPacket
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA.
Summary
PocketMine-MP versions before 5.3.1 and 4.23.1 contain a denial of service vulnerability in LoginPacket JSON parsing due to improper null value handling in arrays. Attackers can send malformed JSON with unexpected null elements in LoginPacket to crash the server.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA PocketMine-MP (pmmp) Fixed in 4.23.1, 5.3.1
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
pmmp PocketMine-MP 4.23.1, 5.3.1
2 records Highest priority Priority MEDIUM 2 MEDIUM
Other records, highest priority first
- TI-2023-30628 PocketMine-MP 5.2.0 Server Crash via Incorrect EC CurvePriority MEDIUM 44
Timeline
- 2026-10-02 Threatist record created from CVE-2023-54390
- 2026-10-03 Alias added: GHSA-q3ff-jxcw-jc3j
References
Patch 1
More pmmp vulnerabilities
- TI-2026-58990 PocketMine-MP before 5.41.1 LogDoS via LoginPacket clientData CVSS 4.0HIGH 8.7
- TI-2026-58988 PocketMine-MP before 5.43.1 Denial of Service via unauthenticated login CVSS 4.0HIGH 8.7
- TI-2026-58993 PocketMine-MP before 5.39.2 Denial of Service via ModalFormResponsePacket CVSS 4.0HIGH 7.1
- TI-2024-38460 PocketMine-MP before 5.11.1 Denial of Service via LoginPacket CVSS 4.0HIGH 8.7
- TI-2023-30643 PocketMine-MP before 4.20.5 Denial of Service via LoginPacket CVSS 4.0HIGH 8.7
- TI-2022-26446 PocketMine-MP before 3.26.5 and 4.0.5 Denial of Service via Skin Data CVSS 4.0HIGH 8.7
Sources
- CVE-2023-54390 · CVE Program
- CVE-2023-54390 · NVD
- FIRST EPSS
- GHSA-q3ff-jxcw-jc3j · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences