PocketMine-MP before 3.26.5 and 4.0.5 Denial of Service via Skin Data
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA.
Summary
PocketMine-MP versions before 3.26.5 and 4.0.5 fail to validate the length of skin data fields submitted by players, allowing uncapped values to exceed the 32767 byte TAG_String limit. Attackers can submit oversized skin data fields like skinID or geometryName to trigger exceptions during NBT data serialization, causing server crashes.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA PocketMine-MP (pmmp) Fixed in 3.26.5, 4.0.5
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
pmmp PocketMine-MP 3.26.5, 4.0.5
2 records Highest priority Priority MEDIUM 1 MEDIUM, 1 LOW
Other records, highest priority first
- TI-2022-26447 PocketMine-MP before 3.26.5 and 4.0.5 Input Validation via Book PagesPriority LOW 32
Timeline
- 2026-10-02 Threatist record created from CVE-2022-51017
- 2026-10-03 Alias added: GHSA-q675-2qq9-hxh3
- 2026-10-28 EPSS moved to the 50th–90th percentile
References
More pmmp vulnerabilities
- TI-2026-58990 PocketMine-MP before 5.41.1 LogDoS via LoginPacket clientData CVSS 4.0HIGH 8.7
- TI-2026-58988 PocketMine-MP before 5.43.1 Denial of Service via unauthenticated login CVSS 4.0HIGH 8.7
- TI-2026-58993 PocketMine-MP before 5.39.2 Denial of Service via ModalFormResponsePacket CVSS 4.0HIGH 7.1
- TI-2024-38460 PocketMine-MP before 5.11.1 Denial of Service via LoginPacket CVSS 4.0HIGH 8.7
- TI-2023-30643 PocketMine-MP before 4.20.5 Denial of Service via LoginPacket CVSS 4.0HIGH 8.7
- TI-2023-30640 PocketMine-MP before 5.3.1 Denial of Service via LoginPacket CVSS 4.0HIGH 8.7
Sources
- CVE-2022-51017 · CVE Program
- CVE-2022-51017 · NVD
- FIRST EPSS
- GHSA-q675-2qq9-hxh3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences