Ultimate Posts Widget < 2.3.1 - Admin+ Stored XSS
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Ultimate Posts Widget WordPress plugin before 2.3.1 does not validate and escape some of its Widget options before outputting them back in attributes, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Ultimate Posts Widget | before 2.3.1 | 2.3.1 | Patch available | CNA |
- Ultimate Posts Widget VendorUnknown Affected before 2.3.1 Fixed in 2.3.1 Patch available CNA
Remediation
- Fix · CNA Ultimate Posts Widget (Unknown) Fixed in 2.3.1
Timeline
- 2026-10-02 Threatist record created from CVE-2024-0561
- 2026-10-03 Alias added: GHSA-hv62-rcrq-hx82
References
More inisev Ultimate Posts Widget vulnerabilities
- TI-2023-00909 Inisev Plugins (Various Versions) - Missing Authorization on handle_installation function CVSS 3.1MEDIUM 6.5
- TI-2023-03692 Inisev Plugins (Various Versions) - Cross-Site Request Forgery on handle_installation function CVSS 3.1MEDIUM 4.3
Sources
- CVE-2024-0561 · CVE Program
- CVE-2024-0561 · NVD
- FIRST EPSS
- GHSA-hv62-rcrq-hx82 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences