Grandstream UCM Series IP PBX HTTP Parameter Injection
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
The Grandstream UCM Series IP PBX before firmware version 1.0.20.52 is affected by a parameter injection vulnerability in the HTTP interface. A remote and authenticated attacker can execute arbitrary code by sending a crafted HTTP request. Authentication may be possible using a default user and password. Affected models are the UCM6202, UCM6204, UCM6208, and UCM6510.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Grandstream | UCM Series | before <1.0.20.52 | <1.0.20.52 | Patch available | CNA |
- UCM Series VendorGrandstream Affected before <1.0.20.52 Fixed in <1.0.20.52 Patch available CNA
CPE names CISA-ADP · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:grandstream:ucm6202_firmware:*:*:*:*:*:*:*:* | — | — | Grandstream |
| cpe:2.3:a:grandstream:ucm6204_firmware:*:*:*:*:*:*:*:* | — | — | Grandstream |
| cpe:2.3:a:grandstream:ucm6208_firmware:*:*:*:*:*:*:*:* | — | — | Grandstream |
| cpe:2.3:a:grandstream:ucm6510_firmware:*:*:*:*:*:*:*:* | — | — | Grandstream |
- cpe:2.3:a:grandstream:ucm6202_firmware:*:*:*:*:*:*:*:* Versions — — ·Grandstream
- cpe:2.3:a:grandstream:ucm6204_firmware:*:*:*:*:*:*:*:* Versions — — ·Grandstream
- cpe:2.3:a:grandstream:ucm6208_firmware:*:*:*:*:*:*:*:* Versions — — ·Grandstream
- cpe:2.3:a:grandstream:ucm6510_firmware:*:*:*:*:*:*:*:* Versions — — ·Grandstream
Remediation
- Fix · CNA UCM Series (Grandstream) Fixed in <1.0.20.52
Timeline
- 2026-10-02 Threatist record created from CVE-2024-0840
- 2026-10-03 Alias added: GHSA-jg72-rmmw-hp49
References
—
More Grandstream vulnerabilities
- TI-2020-04650 SQL injection in Grandstream UCM6200 Series KEVCVSS 3.1CRITICAL 9.8
- TI-2026-01969 Grandstream GXP1600 VoIP Phones - Unauthenticated stack buffer overflow CVSS 4.0CRITICAL 9.3
- TI-2019-07957 Grandstream UCM6204 before 1.0.19.20 devices allow remote authenticated users to execute… CVSS 3.1HIGH 8.8
- TI-2025-20739 Grandstream Networks GXP1628 <=1.0.4.130 is vulnerable to Incorrect Access Control. CVSS 3.1HIGH 7.6
- TI-2024-21804 OS command injection in Grandstream GXP2135 CVSS 3.1CRITICAL 9.8
- TI-2025-20741 Grandstream Networks UCM6510 v1.0.20.52 and before is vulnerable to Improper Restriction… CVSS 3.1MEDIUM 6.5
Sources
- CVE-2024-0840 · CVE Program
- CVE-2024-0840 · NVD
- FIRST EPSS
- GHSA-jg72-rmmw-hp49 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences