Read the docs
TI-2024-00789 Aliases CVE-2024-0855GHSA-g77v-mcj9-92j3

Spiffy Calendar < 4.9.9 - Broken Access Control

Priority MEDIUM 63Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.

Summary

The Spiffy Calendar WordPress plugin before 4.9.9 doesn't check the event_author parameter, and allows any user to alter it when creating an event, leading to deceiving users/admins that a page was created by a Contributor+.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00482 41st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Spiffy Calendar (Unknown): 4.9.9

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownSpiffy Calendarbefore 4.9.94.9.9Patch availableCNA
  • Spiffy Calendar VendorUnknown Affected before 4.9.9 Fixed in 4.9.9 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:spiffyplugins:spiffy_calendar:*:*:*:*:*:wordpress:*:*before 4.9.9VulnerableSpiffy Plugins
  • cpe:2.3:a:spiffyplugins:spiffy_calendar:*:*:*:*:*:wordpress:*:* Versions before 4.9.9 Vulnerable ·Spiffy Plugins

Remediation

  • Fix · CNA Spiffy Calendar (Unknown) Fixed in 4.9.9

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-0855
  2. 2026-10-03 Alias added: GHSA-g77v-mcj9-92j3

References

  • TI-2022-23203 WordPress Spiffy Calendar Plugin <= 4.9.1 is vulnerable to SQL Injection CVSS 3.1CRITICAL 9.8
  • TI-2024-25926 WordPress spiffy-calendar plugin <= 4.9.11 - SQL Injection vulnerability CVSS 3.1HIGH 7.6
  • TI-2024-30501 WordPress Spiffy Calendar plugin <= 4.9.13 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
  • TI-2023-27155 WordPress Spiffy Calendar Plugin <= 4.9.5 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
  • TI-2022-11904 WordPress Spiffy Calendar plugin <= 4.9.0 - Edit/Delete event via IDOR vulnerability CVSS 3.1MEDIUM 6.3
  • TI-2024-30500 WordPress Spiffy Calendar plugin <= 4.9.13 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
See all 10 →

Sources