Widget for Social Page Feeds < 6.4 - Admin+ Stored XSS
Priority MEDIUM 60CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Widget for Social Page Feeds WordPress plugin before 6.4 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00396 34th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Widget for Social Page Feeds (Unknown): 6.4
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Widget for Social Page Feeds | before 6.4 | 6.4 | Patch available | CNA |
- Widget for Social Page Feeds VendorUnknown Affected before 6.4 Fixed in 6.4 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:patelmilap:widget_for_social_page_feeds:*:*:*:*:*:wordpress:*:* | before 6.4 | Vulnerable | Patelmilap |
- cpe:2.3:a:patelmilap:widget_for_social_page_feeds:*:*:*:*:*:wordpress:*:* Versions before 6.4 Vulnerable ·Patelmilap
Remediation
- Fix · CNA Widget for Social Page Feeds (Unknown) Fixed in 6.4
Timeline
- 2026-10-02 Threatist record created from CVE-2024-0973
- 2026-10-03 Alias added: GHSA-vmmc-658q-cfx9
References
More Patelmilap Widget For Social Page Feeds vulnerabilities
- TI-2024-12253 Widget for Social Page Feeds < 6.4.2 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
Sources
- CVE-2024-0973 · CVE Program
- CVE-2024-0973 · NVD
- FIRST EPSS
- GHSA-vmmc-658q-cfx9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences