WAF bypass of the ModSecurity v3 release line
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
ModSecurity / libModSecurity 3.0.0 to 3.0.11 is affected by a WAF bypass for path-based payloads submitted via specially crafted request URLs. ModSecurity v3 decodes percent-encoded characters present in request URLs before it separates the URL path component from the optional query string component. This results in an impedance mismatch versus RFC compliant back-end applications. The vulnerability hides an attack payload in the path component of the URL from WAF rules inspecting it. A back-end may be vulnerable if it uses the path component of request URLs to construct queries. Integrators and users are advised to upgrade to 3.0.12. The ModSecurity v2 release line is not affected by this vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| owasp-modsecurity | ModSecurity | 3.0.0 – 3.0.11 | — | No fix listed | CNA |
- ModSecurity Vendorowasp-modsecurity Affected 3.0.0 – 3.0.11 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:owasp:modsecurity:*:*:*:*:*:*:*:* | 3.0.0 to before 3.0.12 | Vulnerable | owasp-modsecurity |
- cpe:2.3:a:owasp:modsecurity:*:*:*:*:*:*:*:* Versions 3.0.0 to before 3.0.12 Vulnerable ·owasp-modsecurity
Remediation
No fixed version listed by the sources yet.
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2024-1019
- 2026-10-03 Alias added: GHSA-w56r-g989-xqw3
References
More owasp-modsecurity Modsecurity vulnerabilities
- TI-2026-37865 ModSecurity: Multipart form-data parser silently strips embedded line breaks from… CVSS 3.1HIGH 8.6
- TI-2026-30581 ModSecurity: Unsigned integer underflow in @verifySSN / @verifyCPF / @verifySVNR operators CVSS 4.0HIGH 8.2
- TI-2026-23748 libModSecurity3 denial of service via segfault when using t:hexDecode on single-character query strings CVSS 4.0HIGH 8.2
- TI-2025-31022 ModSecurity has possible DoS vulnerability in sanitiseArg action CVSS 3.1HIGH 7.5
- TI-2025-34348 ModSecurity's Insufficient Return Value Handling can Lead to XSS and Source Code Disclosure CVSS 4.0MEDIUM 6.9
- TI-2023-19686 Trustwave ModSecurity 3.x before 3.0.10 has Inefficient Algorithmic Complexity. CVSS 3.1HIGH 7.5
Sources
- CVE-2024-1019 · CVE Program
- CVE-2024-1019 · NVD
- FIRST EPSS
- GHSA-w56r-g989-xqw3 · GitHub Advisory Database · CC BY 4.0
- CVE-2024-1019 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences