EventPrime – Events Calendar, Bookings and Tickets <= 3.4.2 - Missing Authorization to Arbitrary Post Overwrite
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-862.
Summary
The EventPrime – Events Calendar, Bookings and Tickets plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the save_frontend_event_submission() function in all versions up to, and including, 3.4.2. This makes it possible for authenticated attackers, with subscriber-level access and above, to overwrite the title and content of arbitrary posts. This can also be exploited by unauthenticated attackers when the allow_submission_by_anonymous_user setting is enabled.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-1123
- 2026-10-03 Alias added: GHSA-r382-478w-qwfw
References
More Metagauss Eventprime vulnerabilities
- TI-2023-03938 EventPrime <= 3.2.9 - Booking Pricing Bypass CVSS 3.1MEDIUM 5.3
- TI-2024-04340 EventPrime – Events Calendar, Bookings and Tickets < 3.5.0 - Subscriber+ Arbitrary booking settings update CVSS 3.1MEDIUM 6.4
- TI-2023-04816 EventPrime < 3.2.0 - Reflected HTML Injection on keyword parameter CVSS 3.1MEDIUM 6.1
- TI-2023-03936 EventPrime < 3.2.0 - Reflected XSS CVSS 3.1MEDIUM 6.1
- TI-2023-05915 EventPrime < 3.3.6 - Unauthenticated Event Access CVSS 3.1MEDIUM 5.3
- TI-2023-05078 EventPrime < 3.2.0 - Booking Creation via CSRF CVSS 3.1MEDIUM 4.3
Sources
- CVE-2024-1123 · CVE Program
- CVE-2024-1123 · NVD
- FIRST EPSS
- GHSA-r382-478w-qwfw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences