Read the docs
TI-2024-01220 Aliases CVE-2024-1310GHSA-qrqj-j85r-f7h4

WooCommerce < 8.6 - Contributor+ Private/Draft Products Access

Priority LOW 24Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.

Summary

The WooCommerce WordPress plugin before 8.6 does not prevent users with at least the contributor role from leaking products they shouldn't have access to. (e.g. private, draft and trashed products)

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00686 52nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed WooCommerce (Unknown): 8.6

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownWooCommercebefore 8.68.6Patch availableCNA
  • WooCommerce VendorUnknown Affected before 8.6 Fixed in 8.6 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:automattic:woocommerce:*:*:*:*:*:wordpress:*:*before 8.6.0VulnerableAutomattic
  • cpe:2.3:a:automattic:woocommerce:*:*:*:*:*:wordpress:*:* Versions before 8.6.0 Vulnerable ·Automattic

Remediation

  • Fix · CNA WooCommerce (Unknown) Fixed in 8.6

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-1310
  2. 2026-10-03 Alias added: GHSA-qrqj-j85r-f7h4

References

  • TI-2017-12523 The WooCommerce plugin through 3.x for WordPress has a Directory Traversal Vulnerability… CVSS 3.1HIGH 7.5
  • TI-2023-25887 WordPress WooCommerce and WooCommerce Blocks plugins - Auth. Cross-Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5

Sources