EventPrime – Events Calendar, Bookings and Tickets <= 3.4.2 - Unauthenticated Booking Payment Bypass
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-345.
Summary
The EventPrime – Events Calendar, Bookings and Tickets plugin for WordPress is vulnerable to payment bypass in all versions up to, and including, 3.4.2. This is due to the plugin allowing unauthenticated users to update the status of order payments. This makes it possible for unauthenticated attackers to book events for free.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-1321
- 2026-10-03 Alias added: GHSA-jcq2-wpv8-87h7
References
More Metagauss Eventprime vulnerabilities
- TI-2023-03938 EventPrime <= 3.2.9 - Booking Pricing Bypass CVSS 3.1MEDIUM 5.3
- TI-2024-04340 EventPrime – Events Calendar, Bookings and Tickets < 3.5.0 - Subscriber+ Arbitrary booking settings update CVSS 3.1MEDIUM 6.4
- TI-2023-04816 EventPrime < 3.2.0 - Reflected HTML Injection on keyword parameter CVSS 3.1MEDIUM 6.1
- TI-2023-03936 EventPrime < 3.2.0 - Reflected XSS CVSS 3.1MEDIUM 6.1
- TI-2023-05915 EventPrime < 3.3.6 - Unauthenticated Event Access CVSS 3.1MEDIUM 5.3
- TI-2023-05078 EventPrime < 3.2.0 - Booking Creation via CSRF CVSS 3.1MEDIUM 4.3
Sources
- CVE-2024-1321 · CVE Program
- CVE-2024-1321 · NVD
- FIRST EPSS
- GHSA-jcq2-wpv8-87h7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences