Read the docs
TI-2024-01242 Aliases CVE-2024-1333GHSA-gjwh-9473-rcfm

Responsive Pricing Table < 5.1.11 - Author+ Stored XSS

Priority MEDIUM 58CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.

Summary

The Responsive Pricing Table WordPress plugin before 5.1.11 does not validate and escape some of its Pricing Table options before outputting them back in a page/post where the related shortcode is embed, which could allow users with the author role and above to perform Stored Cross-Site Scripting attacks

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00401 34th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Responsive Pricing Table (Unknown): 5.1.11

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownResponsive Pricing Tablebefore 5.1.115.1.11Patch availableCNA
  • Responsive Pricing Table VendorUnknown Affected before 5.1.11 Fixed in 5.1.11 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:wpdarko:responsive_pricing_table:*:*:*:*:*:wordpress:*:*before 5.1.11VulnerableWP Darko
  • cpe:2.3:a:wpdarko:responsive_pricing_table:*:*:*:*:*:wordpress:*:* Versions before 5.1.11 Vulnerable ·WP Darko

Remediation

  • Fix · CNA Responsive Pricing Table (Unknown) Fixed in 5.1.11

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-1333
  2. 2026-10-03 Alias added: GHSA-gjwh-9473-rcfm

References

  • TI-2023-04427 Responsive Pricing Table < 5.1.8 - Admin+ Stored Cross-Site Scriping CVSS 3.1MEDIUM 4.8
  • TI-2022-23199 WordPress Responsive Pricing Table Plugin <= 5.1.6 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5

Sources