Classified Listing – Classified ads & Business Directory Plugin <= 3.0.4 - Missing Authorization
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-862.
Summary
The Classified Listing – Classified ads & Business Directory Plugin plugin for WordPress is vulnerable to unauthorized access & modification of data due to a missing capability check on the rtcl_import_location() rtcl_import_category() functions in all versions up to, and including, 3.0.4. This makes it possible for authenticated attackers, with subscriber-level access and above, to create terms.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| RadiusTheme | Classified Listing – AI-Powered Classified ads & Business Directory Plugin | up to 3.0.4 | — | No fix listed | CNA |
- Classified Listing – AI-Powered Classified ads & Business Directory Plugin VendorRadiusTheme Affected up to 3.0.4 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:radiustheme:classified_listing:*:*:*:*:-:wordpress:*:* | before 3.0.5 | Vulnerable | RadiusTheme |
- cpe:2.3:a:radiustheme:classified_listing:*:*:*:*:-:wordpress:*:* Versions before 3.0.5 Vulnerable ·RadiusTheme
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-1352
- 2026-10-03 Alias added: GHSA-vjgv-q4qp-fr6p
References
More RadiusTheme Classified Listing vulnerabilities
- TI-2022-02454 Classima < 2.1.11 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2024-01224 Classified Listing <= 3.0.4 - Cross-Site Request Forgery to Account Takeover via rtcl_update_user_account CVSS 3.1HIGH 8.8
- TI-2023-19008 WordPress Classified Listing Plugin <= 2.4.5 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2025-00902 Classified Listing – Classified ads & Business Directory Plugin <= 4.0.4 - Unauthenticated Settings Exposure CVSS 3.1MEDIUM 5.3
- TI-2024-07311 Classified Listing – Classified ads & Business Directory Plugin <= 3.1.7 - Missing Authorization CVSS 3.1MEDIUM 6.3
- TI-2022-02455 Classified Listing Pro < 2.0.20 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
Sources
- CVE-2024-1352 · CVE Program
- CVE-2024-1352 · NVD
- FIRST EPSS
- GHSA-vjgv-q4qp-fr6p · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences