Colibri WP <= 1.0.94 - Cross-Site Request Forgery to Limited Plugin Installation
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-352.
Summary
The Colibri WP theme for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.0.94. This is due to missing or incorrect nonce validation on the colibriwp_install_plugin() function. This makes it possible for unauthenticated attackers to install recommended plugins via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| extendthemes | Colibri WP | up to 1.0.94 | — | No fix listed | CNA |
- Colibri WP Vendorextendthemes Affected up to 1.0.94 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-1360
- 2026-10-03 Alias added: GHSA-47rx-9m4v-5f59
References
More extendthemes vulnerabilities
- TI-2025-02014 Kubio AI Page Builder <= 2.5.1 - Unauthenticated Local File Inclusion CVSS 3.1CRITICAL 9.8
- TI-2022-04358 Materialis Companion < 1.3.40 - Contributor+ Stored XSS via Shortcode CVSS 3.1MEDIUM 5.4
- TI-2022-04096 Mesmerize Companion < 1.6.135 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2019-15245 Mesmerize <= 1.6.89 & Materialis <= 1.0.172 - Authenticated Arbitrary Options Update CVSS 3.1HIGH 8.8
- TI-2026-54440 WordPress Lead Generation Contact Widget & AI Chatbot: Chat Button, Phone Call, Telegram… CVSS 3.1HIGH 7.5
- TI-2024-22269 WordPress Teluro theme <= 1.0.31 - Cross Site Request Forgery (CSRF) vulnerability CVSS 3.1HIGH 8.8
Sources
- CVE-2024-1360 · CVE Program
- CVE-2024-1360 · NVD
- FIRST EPSS
- GHSA-47rx-9m4v-5f59 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences